Bug 233682 - 12.0-RC2 - /etc/rc.d/devd takes VERY long at boot
Summary: 12.0-RC2 - /etc/rc.d/devd takes VERY long at boot
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 12.0-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2018-12-01 11:24 UTC by vermaden
Modified: 2018-12-09 23:38 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vermaden 2018-12-01 11:24:31 UTC
The /etc/rc.d/devd takes VERY long at the boot (waiting for something?).

This was not the case in 11.2-RELEASE.
Comment 1 vermaden 2018-12-02 10:08:50 UTC
For the record, same with RC3.
Comment 2 vermaden 2018-12-09 23:38:45 UTC
This was my fault.

Its not a bug.

Its because now my 'automount' - https://github.com/vermaden/automount - does check ugen(4) devices for MTP services and that took too long at boot.

I disabled it at boot (first 45 seconds) and now devd(8) starts fast.

Used code for the record:
| BOOTTIME=$( sysctl -n kern.boottime | awk '{print $4}' | tr -d ',' )
| CURRTIME=$( date +%s )
| DIFFTIME=$(( ${CURRTIME} - ${BOOTTIME} ))
| if [ ${DIFFTIME} -lt 45 ]
| then
|   exit 0
| fi

Regards and sorry for 'fake' bug.