Bug 234104 - sysutils/intel-nvmupdate 6.80 causes immediate reboot
Summary: sysutils/intel-nvmupdate 6.80 causes immediate reboot
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: IntelNetworking, needs-qa
Depends on:
Blocks:
 
Reported: 2018-12-17 19:23 UTC by Finn
Modified: 2019-02-13 16:04 UTC (History)
4 users (show)

See Also:
koobs: merge-quarterly?


Attachments
Patch to ixl(4)'s nvmupdate ioctl handling (2.65 KB, patch)
2018-12-18 22:34 UTC, Eric Joyner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Finn 2018-12-17 19:23:44 UTC
version has been updated in:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=233532

when running
"nvmupdate"
6.80 the system reboots

NIC: X710-DA2



--------
# nvmupdate 

Intel(R) Ethernet NVM Update Tool
NVMUpdate version 1.32.20.30
Copyright (C) 2013 - 2018 Intel Corporation.


WARNING: To avoid damage to your device, do not stop the update or reboot or power off the system during this update.
Inventory in progress. Please wait
------

---> system reboots

"nvmupdate -v" output:
-----------
Intel(R) Ethernet NVM Update Tool
NVMUpdate version 1.32.20.30
Copyright (C) 2013 - 2018 Intel Corporation.

Version:
QV SDK    - 2.32.20.28
ixl       - 2.1.0-k
-----------


"nvmupdate -l nvmupdate.log"
also causes a reboot and does not generate a log file.

"nvmupate -i" 
also causes a reboot.


FreeBSD 12.0-RELEASE

dev.ixl.0.fw_version: fw 6.0.48442 api 1.7 nvm 6.01 etid 800035cf oem 1.262.0
Comment 1 Bugzilla Automation freebsd_committer 2018-12-17 19:23:44 UTC
Maintainer informed via mail
Comment 2 Eric Joyner freebsd_committer 2018-12-18 22:34:27 UTC
Created attachment 200243 [details]
Patch to ixl(4)'s nvmupdate ioctl handling

Could you try this patch to ixl? This problem doesn't show up on all of my systems, so this issue requires more debugging for a root cause, but this does solve the issue on a machine I had that was rebooting.
Comment 3 Finn 2019-01-08 23:16:15 UTC
I can test and provide feedback once this is available as binary update.
Comment 4 Kurt Jaeger freebsd_committer 2019-01-09 07:22:46 UTC
the fix will only be committed if someone tests it 8-}

Teufelskreis 8-)
Comment 5 Krzysztof Galazka 2019-01-11 09:01:18 UTC
The blame is actually on both sides - the driver and the tool. This patch fixes the driver bug and workarounds problem with the nvmupdate:

https://reviews.freebsd.org/D18817
Comment 6 commit-hook freebsd_committer 2019-01-24 01:09:29 UTC
A commit references this bug:

Author: erj
Date: Thu Jan 24 01:08:37 UTC 2019
New revision: 343372
URL: https://svnweb.freebsd.org/changeset/base/343372

Log:
  ixl(4): Fix handling data passed with ioctl from NVM update tool

  From Krzysztof:

  Ensure that the entire data buffer passed from the NVM update tool is copied in
  to kernel space and copied back out to user space using copyin() and copyout().

  PR:		234104
  Submitted by:	Krzysztof Galazka <krzysztof.galazka@intel.com>
  Reported by:	Finn <ixbug@riseup.net>
  MFC after:	5 days
  Sponsored by:	Intel Corporation
  Differential Revision:	https://reviews.freebsd.org/D18817

Changes:
  head/sys/dev/ixl/ixl_pf_main.c
Comment 7 commit-hook freebsd_committer 2019-02-13 16:03:24 UTC
A commit references this bug:

Author: marius
Date: Wed Feb 13 16:02:52 UTC 2019
New revision: 344104
URL: https://svnweb.freebsd.org/changeset/base/344104

Log:
  MFC: r343372

  ixl(4): Fix handling data passed with ioctl from NVM update tool

  From Krzysztof:

  Ensure that the entire data buffer passed from the NVM update tool is copied in
  to kernel space and copied back out to user space using copyin() and copyout().

  PR:		234104
  Submitted by:	Krzysztof Galazka <krzysztof.galazka@intel.com>
  Reported by:	Finn <ixbug@riseup.net>
  Differential Revision:	https://reviews.freebsd.org/D18817

Changes:
_U  stable/12/
  stable/12/sys/dev/ixl/ixl_pf_main.c
Comment 8 commit-hook freebsd_committer 2019-02-13 16:03:27 UTC
A commit references this bug:

Author: marius
Date: Wed Feb 13 16:02:56 UTC 2019
New revision: 344105
URL: https://svnweb.freebsd.org/changeset/base/344105

Log:
  MFC: r343372

  ixl(4): Fix handling data passed with ioctl from NVM update tool

  From Krzysztof:

  Ensure that the entire data buffer passed from the NVM update tool is copied in
  to kernel space and copied back out to user space using copyin() and copyout().

  PR:		234104
  Submitted by:	Krzysztof Galazka <krzysztof.galazka@intel.com>
  Reported by:	Finn <ixbug@riseup.net>
  Differential Revision:	https://reviews.freebsd.org/D18817

Changes:
_U  stable/11/
  stable/11/sys/dev/ixl/ixl_pf_main.c
Comment 9 Marius Strobl freebsd_committer 2019-02-13 16:04:22 UTC
Close; thanks for the report!