Bug 234396 - deskutils/gnome-font-viewer: fix build on GCC-based architectures
Summary: deskutils/gnome-font-viewer: fix build on GCC-based architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
: 233714 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-12-25 12:35 UTC by Mark Linimon
Modified: 2019-01-14 01:11 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
patch to deskutils/gnome-font-viewer/Makefile (533 bytes, patch)
2018-12-25 12:35 UTC, Mark Linimon
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Linimon freebsd_committer freebsd_triage 2018-12-25 12:35:52 UTC
Created attachment 200499 [details]
patch to deskutils/gnome-font-viewer/Makefile

USES compiler:c11 is needed to fix the build on GCC-based architectures such as powerpc64.

Tested on powerpc64, amd64.

Suggested by: jhibbits
Comment 1 Piotr Kubaj freebsd_committer 2018-12-25 14:24:31 UTC
*** Bug 233714 has been marked as a duplicate of this bug. ***
Comment 2 commit-hook freebsd_committer 2019-01-14 01:11:11 UTC
A commit references this bug:

Author: linimon
Date: Mon Jan 14 01:10:29 UTC 2019
New revision: 490221
URL: https://svnweb.freebsd.org/changeset/ports/490221

Log:
  USES compiler:c11 is needed to fix the build on GCC-based architectures
  such as powerpc64.

  PR:		234396
  Approved by:	portmgr (tier-2 blanket)

Changes:
  head/deskutils/gnome-font-viewer/Makefile