Bug 234419 - lang/gcc8: Fix for powerpcspe
Summary: lang/gcc8: Fix for powerpcspe
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-12-26 16:59 UTC by Justin Hibbits
Modified: 2019-09-03 05:21 UTC (History)
3 users (show)

See Also:
gerald: maintainer-feedback+


Attachments
Patch against the files/patch-spe-config file (1.38 KB, patch)
2018-12-26 16:59 UTC, Justin Hibbits
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Hibbits freebsd_committer 2018-12-26 16:59:28 UTC
Created attachment 200532 [details]
Patch against the files/patch-spe-config file

Fix lang/gcc8, which needs additional case blocks due to powerpcspe being split out from rs6000 config.
Comment 1 Gerald Pfeifer freebsd_committer 2019-01-19 19:26:59 UTC
Thanks for the report and proposing a patch even, Justin!

'm back from some time off and in principle this looks okay for me,
assuming you have successfully tested it.

However, we really shouldn't carry this as a local patch, but get it
upstream (first). -> Andreas, is this something you can help with?
Comment 2 Justin Hibbits freebsd_committer 2019-01-19 21:11:41 UTC
I have successfully tested it, yes.  I've built several hundred ports with this compiler now on my AmigaOne A1222 board.
Comment 3 Gerald Pfeifer freebsd_committer 2019-01-19 21:44:43 UTC
Thanks for the confirmation.

And apologies, I mis-read the diff at first:  Of course it doesn't
patch from scratch, but the existing files/patch-spe-config we have
in lang/gcc8.

So, happy to approve if^Wsince it works for you.

Do you want to commit this yourself?  In that case
  Approved by: gerald
Otherwise advise, and I'll commit it (with proper attribution).
Comment 4 Justin Hibbits freebsd_committer 2019-01-19 22:24:55 UTC
You can do the honors.  I don't have a committable ports tree checked out.
Comment 5 commit-hook freebsd_committer 2019-01-20 12:49:13 UTC
A commit references this bug:

Author: gerald
Date: Sun Jan 20 12:49:05 UTC 2019
New revision: 490785
URL: https://svnweb.freebsd.org/changeset/ports/490785

Log:
  Update files/patch-spe-config (and with that our local adjustments to
  config.gcc) to the changed directory structure under gcc/config brought
  by GCC 8 when powerpcspe was cloned and broken out from the regular
  powerpc port.

  PR:		234419
  Submitted by:	jhibbits
  MFH:		2019Q1 (build fix on powerpcspe)

Changes:
  head/lang/gcc8/files/patch-spe-config
Comment 6 Gerald Pfeifer freebsd_committer 2019-01-20 12:55:59 UTC
Thank you.

lang/gcc8 should be fine now.  I'm leaving this bug report open for now
since I requested an MFH to the 2019Q1 ports tree and will also address
gcc8-devel and gcc9-devel in the next days.

In the case of gcc9-devel that means removing the entire patch since in
December GCC upstream removed support for powerpcspe based on utter lack
of maintenance.
Comment 7 commit-hook freebsd_committer 2019-01-24 16:54:40 UTC
A commit references this bug:

Author: gerald
Date: Thu Jan 24 16:53:38 UTC 2019
New revision: 491099
URL: https://svnweb.freebsd.org/changeset/ports/491099

Log:
  Update to the 20180118 snapshot of GCC 8.2.1.

  Forward port r490785 | gerald | 2019-01-20 from lang/gcc8: [1]

    Update files/patch-spe-config (and with that our local adjustments to
    config.gcc) to the changed directory structure under gcc/config brought
    by GCC 8 when powerpcspe was cloned and broken out from the regular
    powerpc port.

  PR:		234419 [1]
  Submitted by:	jhibbits [1]
  MFH:		2019Q1 (build fix on powerpcspe) [1]

Changes:
  head/lang/gcc8-devel/Makefile
  head/lang/gcc8-devel/distinfo
  head/lang/gcc8-devel/files/patch-spe-config
Comment 8 commit-hook freebsd_committer 2019-01-26 09:22:36 UTC
A commit references this bug:

Author: gerald
Date: Sat Jan 26 09:21:58 UTC 2019
New revision: 491253
URL: https://svnweb.freebsd.org/changeset/ports/491253

Log:
  Update to the 20190120 snapshot of GCC 9.

  Support for powerpcspe has been removed from upstream GCC in preparation
  of the GCC 9 release, so adjust ONLY_FOR_ARCHS and remove our local patch
  files/patch-spe-config that we still carry until lang/gcc8 and gcc8-devel.

  PR:		234419

Changes:
  head/lang/gcc9-devel/Makefile
  head/lang/gcc9-devel/distinfo
  head/lang/gcc9-devel/files/patch-spe-config
Comment 9 Gerald Pfeifer freebsd_committer 2019-01-26 19:49:15 UTC
Having now patched gcc8 and gcc8-devel as suggested by Justin (Thanks!)
and adjusted gcc9-devel (and implicitly gcc9 which will fork in a bit),
I believe we've done everything possible.

And at least thrice as much as indicated by the title of this PR. :-)

So, let me close this PR, but should there be anything else - or something
not working as intended - please advise!
Comment 10 Justin Hibbits freebsd_committer 2019-01-27 20:55:20 UTC
Thanks, Gerald!
Comment 11 Octavio Steffen 2019-09-03 05:21:01 UTC
MARKED AS SPAM