Bug 234567 - FreeBSD 12.0: periodically panics
Summary: FreeBSD 12.0: periodically panics
Status: Closed DUPLICATE of bug 234296
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.0-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords: crash, needs-qa
Depends on:
Blocks:
 
Reported: 2019-01-02 12:49 UTC by Martin Birgmeier
Modified: 2019-02-06 01:25 UTC (History)
2 users (show)

See Also:
koobs: mfc-stable11?
koobs: mfc-stable12?


Attachments
boot messages - dmesg.boot (12.55 KB, text/plain)
2019-01-02 12:49 UTC, Martin Birgmeier
no flags Details
kernel config file (XYZZY_SMP) (1.67 KB, text/plain)
2019-01-02 12:59 UTC, Martin Birgmeier
no flags Details
complete debug session for 2nd crash (18.05 KB, text/plain)
2019-01-02 13:11 UTC, Martin Birgmeier
no flags Details
complete debug session for 3rd crash (16.46 KB, text/plain)
2019-01-02 14:13 UTC, Martin Birgmeier
no flags Details
complete debug session for 4th crash (17.32 KB, text/plain)
2019-01-05 12:05 UTC, Martin Birgmeier
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2019-01-02 12:49:25 UTC
Created attachment 200707 [details]
boot messages - dmesg.boot

Since upgrading three of my machines from 11.2 to 12.0, one of them (the oldest) periodically crashes.

kgdb shows the following:

(kgdb) where
#0  doadump (textdump=1) at pcpu.h:230
#1  0xffffffff80498950 in kern_reboot (howto=260)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_shutdown.c:446
#2  0xffffffff80498de3 in vpanic (fmt=<value optimized out>, 
    ap=<value optimized out>)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_shutdown.c:872
#3  0xffffffff80498bd3 in panic (fmt=<value optimized out>)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_shutdown.c:799
#4  0xffffffff8073bf3f in trap_fatal (frame=0xfffffe0000472820, eva=211)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/amd64/amd64/trap.c:929
#5  0xffffffff8073bf99 in trap_pfault (frame=0xfffffe0000472820, usermode=0)
    at pcpu.h:230
#6  0xffffffff8073b5be in trap (frame=0xfffffe0000472820)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/amd64/amd64/trap.c:441
#7  0xffffffff807180b5 in calltrap ()
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/amd64/amd64/exception.S:232
#8  0xffffffff8052bf5b in sowakeup (so=0x0, sb=<value optimized out>)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/uipc_sockbuf.c:339
#9  0xffffffff80606aa2 in udp_append (inp=<value optimized out>, 
    ip=<value optimized out>, n=<value optimized out>, off=28, 
    udp_in=0xfffffe0000472990)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/netinet/udp_usrreq.c:385
#10 0xffffffff8060642b in udp_input (mp=<value optimized out>, 
    offp=<value optimized out>, proto=17)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/netinet/udp_usrreq.c:747
#11 0xffffffff805d76a8 in ip_input (m=0x0)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/netinet/ip_input.c:827
#12 0xffffffff805b3353 in swi_net (arg=<value optimized out>)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/net/netisr.c:901
#13 0xffffffff804621b7 in ithread_loop (arg=<value optimized out>)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_intr.c:1043
#14 0xffffffff8045efb3 in fork_exit (
    callout=0xffffffff80462010 <ithread_loop>, arg=0xfffff8000204a920, 
    frame=0xfffffe0000472c00)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_fork.c:1057
#15 0xffffffff8071909e in fork_trampoline ()
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/amd64/amd64/exception.S:993
#16 0x0000000000000000 in ?? ()
Current language:  auto; currently minimal
(kgdb) 

Attached: dmesg.boot.
Comment 1 Martin Birgmeier 2019-01-02 12:57:19 UTC
Next crash:

(kgdb) where
#0  doadump (textdump=1) at pcpu.h:230
#1  0xffffffff80498950 in kern_reboot (howto=260)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_shutdown.c:446
#2  0xffffffff80498de3 in vpanic (fmt=<value optimized out>, 
    ap=<value optimized out>)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_shutdown.c:872
#3  0xffffffff80498bd3 in panic (fmt=<value optimized out>)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_shutdown.c:799
#4  0xffffffff8073bf3f in trap_fatal (frame=0xfffffe001e711610, eva=0)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/amd64/amd64/trap.c:929
#5  0xffffffff8073bf99 in trap_pfault (frame=0xfffffe001e711610, usermode=0)
    at pcpu.h:230
#6  0xffffffff8073b5be in trap (frame=0xfffffe001e711610)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/amd64/amd64/trap.c:441
#7  0xffffffff807180b5 in calltrap ()
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/amd64/amd64/exception.S:232
#8  0xffffffff8045230b in kqueue_kevent (kq=0xfffff8000f0f0000, 
    td=0xfffff8000fb36000, nchanges=<value optimized out>, nevents=64, 
    k_ops=0x0, timeout=0xfffff8000fb36000) at uma.h:408
#9  0xffffffff80451545 in kern_kevent (td=0xfffff8000fb36000, 
    fd=<value optimized out>, nchanges=0, nevents=64, 
    k_ops=0xfffffe001e711aa0, timeout=0x0)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_event.c:1265
#10 0xffffffff80451251 in kern_kevent_generic (td=0xfffff8000fb36000, 
    uap=0xfffffe001e711a70, k_ops=0xfffffe001e711aa0, 
    struct_name=0xffffffff808019d3 "kevent")
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_event.c:1064
#11 0xffffffff80451171 in sys_kevent (td=<value optimized out>, 
    uap=<value optimized out>)
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/kern/kern_event.c:1037
#12 0xffffffff8073c9fb in amd64_syscall (td=0xfffff8000fb36000, traced=0)
    at subr_syscall.c:135
#13 0xffffffff8071899d in fast_syscall_common ()
    at /.../hal/z/SRC/FreeBSD/releng/12.0/sys/amd64/amd64/exception.S:504
#14 0x0000000800c1c1ea in ?? ()
Previous frame inner to this frame (corrupt stack?)
Current language:  auto; currently minimal
(kgdb)
Comment 2 Martin Birgmeier 2019-01-02 12:59:20 UTC
Created attachment 200708 [details]
kernel config file (XYZZY_SMP)

kernel configuration file
Comment 3 Martin Birgmeier 2019-01-02 13:11:58 UTC
Created attachment 200710 [details]
complete debug session for 2nd crash
Comment 4 Martin Birgmeier 2019-01-02 14:13:15 UTC
Created attachment 200712 [details]
complete debug session for 3rd crash

just crashed again - kgdb output attached
Comment 5 Martin Birgmeier 2019-01-02 14:55:59 UTC
Maybe it is related to mpd5 (netgraph using pppoe) - there seem to be fewer panics if there is less traffic across the ng0 interface (uplink to my provider).

Just a hunch, could be something completely different.
Comment 6 Martin Birgmeier 2019-01-05 12:05:43 UTC
Created attachment 200794 [details]
complete debug session for 4th crash
Comment 7 Mark Johnston freebsd_committer 2019-01-10 21:15:50 UTC
Martin, would you be willing to share at least the core.txt for the 4th crash?  I could also look at the kernel dump itself, in which case I need the vmcore, /boot/kernel and /usr/lib/debug/boot/kernel.
Comment 8 Martin Birgmeier 2019-01-11 15:07:02 UTC
Hi Mark,

Thank you for your reply. I have prepared an encrypted compressed file, unfortunately I do not have a webspace where I could host it. It has 51 MB.

Would you happen to have somewhere I could upload this?

I would then send you the PW via mail.

-- Martin
Comment 9 Mark Johnston freebsd_committer 2019-01-11 19:32:21 UTC
(In reply to Martin Birgmeier from comment #8)
I don't have anything handy.  Can you share it via google drive?  If not, please mail me and we'll figure something out.
Comment 10 Mark Johnston freebsd_committer 2019-02-06 01:25:45 UTC
Martin confirmed privately that the fix for PR 234296 addressed his panics.

*** This bug has been marked as a duplicate of bug 234296 ***