Bug 234773 - www/chromium: Closing tab for this web site causes chromium to crash
Summary: www/chromium: Closing tab for this web site causes chromium to crash
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-chromium mailing list
URL:
Keywords:
: 226526 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-09 03:44 UTC by Rob Belics
Modified: 2019-06-17 05:07 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (chromium)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rob Belics 2019-01-09 03:44:13 UTC
If you open this web site, and have other tabs open, close the tab for this site and chromium will crash: https://www.aaron-gustafson.com/notebook/insert-clickbait-headline-about-progressive-enhancement-here/

Sorry I didn't save the console output. If it doesn't crash for you, I'll do it again and post the output.

Chromium Version 71.0.3578.98 (Official Build) (64-bit)
FreeBSD 12.0-RELEASE
Comment 1 Carlos J. Puga Medina freebsd_committer 2019-01-09 09:57:04 UTC
(In reply to Rob Belics from comment #0)

I can reproduce the issue with chromium 71.0.3578.98 on 12.0-RELEASE/amd64.

Can you provide the console output when chromium crashes?
Comment 2 Carlos J. Puga Medina freebsd_committer 2019-01-09 10:33:48 UTC
A temporary fix is to disable JavaScript for the website through the chromium settings.
Comment 3 Rob Belics 2019-01-09 16:09:00 UTC
(In reply to Carlos J. Puga Medina from comment #1)

This is the only output in the terminal when it crashed with one other tab open:

[39720:314204160:0109/100451.970834:ERROR:x11_input_method_context_impl_gtk.cc(144)] Not implemented reached in virtual void libgtkui::X11InputMethodContextImplGtk::SetSurroundingText(const base::string16 &, const gfx::Range &)
[39720:372534272:0109/100451.990274:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.Notifications.GetCapabilities: object_path= /org/freedesktop/Notifications: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
Illegal instruction
Comment 4 Carlos J. Puga Medina freebsd_committer 2019-01-09 19:12:28 UTC
It is probably related to the following bug:

https://bugs.chromium.org/p/chromium/issues/detail?id=914048
Comment 5 Alexander Zagrebin 2019-01-12 20:28:11 UTC
(In reply to Rob Belics from comment #3)

It seems the same problem can be reproduced on opening https://translate.yandex.ru/

Chromium crashes with writing "Illegal instruction" to console.

I'm using chromium-71.0.3578.98_2 on 11.2-RELEASE.

Could anybody confirm that?
Comment 6 Carlos J. Puga Medina freebsd_committer 2019-01-12 21:09:58 UTC
(In reply to Alexander Zagrebin from comment #5)

Confirmed. There is some piece of code where FreeBSD is not defined and chromium crashes. I'm working on a solution.
Comment 7 Rene Ladan freebsd_committer 2019-02-06 20:33:51 UTC
With the patch applied the aaron-gustafson site still crashes upon closing (or going to the previous page with the back arrow) but does not print anything on the console except for "Illegal instruction".
Comment 8 Rene Ladan freebsd_committer 2019-02-06 20:41:25 UTC
(In reply to Alexander Zagrebin from comment #5)
With the patch applied the aaron-gustafson site still crashes upon closing (or going to the previous page with the back arrow) but does not print anything on the console except for "Illegal instruction".
Comment 9 Carlos J. Puga Medina freebsd_committer 2019-02-09 17:51:15 UTC
(In reply to Rene Ladan from comment #7)

This issue is fixed in chromium 72.0.3626.96.

I'm doing some tests and for now chromium doesn't crash.
Comment 10 Carlos J. Puga Medina freebsd_committer 2019-02-09 18:03:44 UTC
I forgot to comment that the latest version is in my repository

https://github.com/cpu82/freebsd-chromium

I must thank Matthias Wolf for his great work to update the chromium port.
Comment 11 commit-hook freebsd_committer 2019-02-24 10:53:13 UTC
A commit references this bug:

Author: rene
Date: Sun Feb 24 10:52:56 UTC 2019
New revision: 493750
URL: https://svnweb.freebsd.org/changeset/ports/493750

Log:
  www/chromium: update to 72.0.3626.119 [1]

  PR:		234773
  Submitted by:	cpm [1], Matthias Wolf [1]
  Obtained from:	https://github.com/cpu82/freebsd-chromium.git
  MFH:		2019Q1

Changes:
  head/www/chromium/Makefile
  head/www/chromium/distinfo
  head/www/chromium/files/patch-base_BUILD.gn
  head/www/chromium/files/patch-base_allocator_partition_allocator_page_allocator.cc
  head/www/chromium/files/patch-base_allocator_partition_allocator_page_allocator_internals_posix.h
  head/www/chromium/files/patch-base_process_launch__posix.cc
  head/www/chromium/files/patch-base_process_process__info__linux.cc
  head/www/chromium/files/patch-base_process_process__linux.cc
  head/www/chromium/files/patch-base_process_process__metrics__freebsd.cc
  head/www/chromium/files/patch-base_sys__info__freebsd.cc
  head/www/chromium/files/patch-base_sys__info__posix.cc
  head/www/chromium/files/patch-base_system_sys__info__freebsd.cc
  head/www/chromium/files/patch-base_system_sys__info__posix.cc
  head/www/chromium/files/patch-base_threading_platform__thread__linux.cc
  head/www/chromium/files/patch-base_trace__event_malloc_dump_provider.cc
  head/www/chromium/files/patch-build_config_BUILD.gn
  head/www/chromium/files/patch-build_config_BUILDCONFIG.gn
  head/www/chromium/files/patch-build_config_compiler_BUILD.gn
  head/www/chromium/files/patch-chrome_app_chrome__main__delegate.cc
  head/www/chromium/files/patch-chrome_app_chromium__strings.grd
  head/www/chromium/files/patch-chrome_app_google__chrome__strings.grd
  head/www/chromium/files/patch-chrome_app_shutdown__signal__handlers__posix.cc
  head/www/chromium/files/patch-chrome_browser_about__flags.cc
  head/www/chromium/files/patch-chrome_browser_after__startup__task__utils.cc
  head/www/chromium/files/patch-chrome_browser_browser__process__impl.cc
  head/www/chromium/files/patch-chrome_browser_browser__process__impl.h
  head/www/chromium/files/patch-chrome_browser_chrome__browser__main.cc
  head/www/chromium/files/patch-chrome_browser_chrome__content__browser__client.cc
  head/www/chromium/files/patch-chrome_browser_download_download__item__model.cc
  head/www/chromium/files/patch-chrome_browser_extensions_bookmark__app__helper.cc
  head/www/chromium/files/patch-chrome_browser_extensions_browser__context__keyed__service__factories.cc
  head/www/chromium/files/patch-chrome_browser_policy_configuration__policy__handler__list__factory.cc
  head/www/chromium/files/patch-chrome_browser_policy_machine__level__user__cloud__policy__controller.cc
  head/www/chromium/files/patch-chrome_browser_prefs_browser__prefs.cc
  head/www/chromium/files/patch-chrome_browser_prefs_pref_service_incognito_whitelist.cc
  head/www/chromium/files/patch-chrome_browser_profiles_profile__attributes__entry.cc
  head/www/chromium/files/patch-chrome_browser_safe__browsing_incident__reporting_incident__reporting__service.cc
  head/www/chromium/files/patch-chrome_browser_signin_signin__util.cc
  head/www/chromium/files/patch-chrome_browser_speech_tts__controller__impl.cc
  head/www/chromium/files/patch-chrome_browser_task__manager_sampling_task__group__sampler.cc
  head/www/chromium/files/patch-chrome_browser_ui_tab__helpers.cc
  head/www/chromium/files/patch-chrome_browser_ui_toolbar_app__menu__model.cc
  head/www/chromium/files/patch-chrome_browser_ui_views_frame_browser__view.cc
  head/www/chromium/files/patch-chrome_browser_ui_views_frame_browser__view.h
  head/www/chromium/files/patch-chrome_common_chrome__switches.cc
  head/www/chromium/files/patch-chrome_common_features.gni
  head/www/chromium/files/patch-chromecast_browser_tts_tts__controller__impl.cc
  head/www/chromium/files/patch-components_crash_content_app_crashpad.cc
  head/www/chromium/files/patch-components_download_quarantine_quarantine_linux.cc
  head/www/chromium/files/patch-components_download_quarantine_test_support_linux.cc
  head/www/chromium/files/patch-components_plugins_renderer_plugin__placeholder.cc
  head/www/chromium/files/patch-components_policy_core_common_cloud_cloud__policy__util.cc
  head/www/chromium/files/patch-components_policy_resources_policy__templates.json
  head/www/chromium/files/patch-components_policy_tools_generate__policy__source.py
  head/www/chromium/files/patch-content_app_content_main_runner_impl.cc
  head/www/chromium/files/patch-content_browser_scheduler_responsiveness_native__event__observer.cc
  head/www/chromium/files/patch-content_browser_scheduler_responsiveness_native__event__observer.h
  head/www/chromium/files/patch-content_browser_service__manager_service__manager__context.cc
  head/www/chromium/files/patch-content_browser_service_worker_service_worker_fetch_dispatcher.cc
  head/www/chromium/files/patch-content_browser_webui_shared__resources__data__source.cc
  head/www/chromium/files/patch-content_gpu_BUILD.gn
  head/www/chromium/files/patch-content_ppapi__plugin_ppapi__blink__platform__impl.cc
  head/www/chromium/files/patch-content_ppapi__plugin_ppapi__blink__platform__impl.h
  head/www/chromium/files/patch-content_ppapi_plugin_ppapi_plugin_main.cc
  head/www/chromium/files/patch-content_renderer_media_audio_audio__device__factory.cc
  head/www/chromium/files/patch-content_renderer_renderer__blink__platform__impl.cc
  head/www/chromium/files/patch-content_renderer_renderer__blink__platform__impl.h
  head/www/chromium/files/patch-content_utility_utility__blink__platform__with__sandbox__support__impl.cc
  head/www/chromium/files/patch-content_utility_utility__blink__platform__with__sandbox__support__impl.h
  head/www/chromium/files/patch-extensions_common_api__permission_features.json
  head/www/chromium/files/patch-extensions_common_image__util.cc
  head/www/chromium/files/patch-gpu_command_buffer_common_gpu_memory_buffer_support.cc
  head/www/chromium/files/patch-gpu_config_gpu__control__list.cc
  head/www/chromium/files/patch-gpu_ipc_common_gpu_memory_buffer_support.cc
  head/www/chromium/files/patch-gpu_ipc_common_gpu_memory_buffer_support.h
  head/www/chromium/files/patch-gpu_ipc_service_gpu_watchdog_thread.cc
  head/www/chromium/files/patch-gpu_ipc_service_gpu_watchdog_thread.h
  head/www/chromium/files/patch-headless_lib_browser_headless__content__browser__client.h
  head/www/chromium/files/patch-headless_lib_browser_headless__request__context__manager.cc
  head/www/chromium/files/patch-media_audio_audio__manager.cc
  head/www/chromium/files/patch-media_capture_video_shared_memory_handler_provider.cc
  head/www/chromium/files/patch-media_capture_video_shared_memory_handler_provider.h
  head/www/chromium/files/patch-mojo_public_js_mojo__bindings__resources.grd
  head/www/chromium/files/patch-net_BUILD.gn
  head/www/chromium/files/patch-net_base_network__interfaces__freebsd.cc
  head/www/chromium/files/patch-net_base_network__interfaces__freebsd.h
  head/www/chromium/files/patch-net_features.gni
  head/www/chromium/files/patch-net_socket_udp__socket__posix.cc
  head/www/chromium/files/patch-services_device_hid_hid__connection__freebsd.cc
  head/www/chromium/files/patch-services_device_hid_hid__service__freebsd.cc
  head/www/chromium/files/patch-services_network_network__service.h
  head/www/chromium/files/patch-services_service__manager_zygote_host_zygote_host_impl_linux.h
  head/www/chromium/files/patch-third__party_angle_src_libANGLE_Display.cpp
  head/www/chromium/files/patch-third__party_blink_renderer_core_paint_paint__layer.cc
  head/www/chromium/files/patch-third__party_blink_renderer_platform_fonts_font__unique__name__lookup.cc
  head/www/chromium/files/patch-third__party_blink_renderer_platform_fonts_shaping_harfbuzz__face.cc
  head/www/chromium/files/patch-third__party_pdfium_fxjs_fx__date__helpers.cpp
  head/www/chromium/files/patch-third__party_pdfium_fxjs_js__define.cpp
  head/www/chromium/files/patch-third__party_pdfium_third__party_base_logging.h
  head/www/chromium/files/patch-third__party_perfetto_src_tracing_core_tracing__service__impl.cc
  head/www/chromium/files/patch-third__party_skia_src_ports_SkFontHost_Freetype.cpp
  head/www/chromium/files/patch-third__party_swiftshader_BUILD.gn
  head/www/chromium/files/patch-third__party_swiftshader_src_Main_SwiftConfig.cpp
  head/www/chromium/files/patch-third__party_swiftshader_src_OpenGL_libEGL_Display.cpp
  head/www/chromium/files/patch-third__party_swiftshader_src_OpenGL_libEGL_Surface.cpp
  head/www/chromium/files/patch-third__party_webrtc_modules_rtp__rtcp_source_forward__error__correction.cc
  head/www/chromium/files/patch-third__party_webrtc_rtc_base_ipaddress.cc
  head/www/chromium/files/patch-third__party_webrtc_rtc_base_ipaddress.h
  head/www/chromium/files/patch-third__party_webrtc_rtc_base_platform_thread.cc
  head/www/chromium/files/patch-third__party_webrtc_rtc_base_stringutils.h
  head/www/chromium/files/patch-third__party_webrtc_webrtc.gni
  head/www/chromium/files/patch-third__party_zlib_arm__features.c
  head/www/chromium/files/patch-third_party_blink_renderer_platform_fonts_font_cache.cc
  head/www/chromium/files/patch-third_party_blink_renderer_platform_fonts_font_cache.h
  head/www/chromium/files/patch-third_party_blink_renderer_platform_fonts_skia_font_cache_skia.cc
  head/www/chromium/files/patch-third_party_crashpad_crashpad_client_BUILD.gn
  head/www/chromium/files/patch-third_party_crashpad_crashpad_client_crashpad_client_posix.cc
  head/www/chromium/files/patch-tools_gn_base_files_file__posix.cc
  head/www/chromium/files/patch-tools_gn_bootstrap_bootstrap.py
  head/www/chromium/files/patch-tools_gn_build_gen.py
  head/www/chromium/files/patch-tools_gn_tools_gn_args.cc
  head/www/chromium/files/patch-tools_gn_util_exe__path.cc
  head/www/chromium/files/patch-tools_gn_util_semaphore.cc
  head/www/chromium/files/patch-tools_gn_util_semaphore.h
  head/www/chromium/files/patch-tools_gn_util_ticks.cc
  head/www/chromium/files/patch-tools_variations_fieldtrial__to__struct.py
  head/www/chromium/files/patch-ui_gfx_font__render__params.h
  head/www/chromium/files/patch-ui_gfx_mojo_buffer_types_struct_traits.cc
  head/www/chromium/files/patch-ui_gfx_mojo_buffer_types_struct_traits.h
  head/www/chromium/files/patch-v8_BUILD.gn
  head/www/chromium/files/patch-v8_src_api.cc
  head/www/chromium/files/patch-v8_src_builtins_builtins-iterator-gen.cc
  head/www/chromium/files/patch-v8_src_builtins_builtins-string-gen.cc
  head/www/chromium/files/patch-v8_src_builtins_builtins-string-gen.h
  head/www/chromium/files/patch-v8_src_trap-handler_handler-inside-posix.cc
  head/www/chromium/files/patch-v8_src_trap-handler_handler-inside-posix.h
  head/www/chromium/files/patch-v8_src_trap-handler_trap-handler.h
  head/www/chromium/pkg-plist
Comment 12 Carlos J. Puga Medina freebsd_committer 2019-03-01 19:30:59 UTC
The issue has been fixed after update chromium to 72.0.3626.119 release.
Comment 13 Jan Beich freebsd_committer 2019-06-17 05:07:37 UTC
*** Bug 226526 has been marked as a duplicate of this bug. ***