Created attachment 201303 [details]
While lv2 itself works fine with any Python version we support, the build fails using a Python greater than 3.6, since the build pulls in and uses an old version of waf. waf upstream fixed the bug in a later version:
Restrict Python to 3.6 and under for now.
This passes poudriere-testport.
There are several missing dependencies. I get the following warnings:
Warning: you need USE_GNOME+=gdkpixbuf2
Error: /usr/local/lib/lv2/eg-sampler.lv2/sampler_ui.so is linked to /usr/local/lib/libfontconfig.so.1 from x11-fonts/fontconfig but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libfontconfig.so:x11-fonts/fontconfig
Error: /usr/local/lib/lv2/eg-sampler.lv2/sampler_ui.so is linked to /usr/local/lib/libfreetype.so.6 from print/freetype2 but it is not declared as a dependency
Warning: you need LIB_DEPENDS+=libfreetype.so:print/freetype2
Please have a look.
Created attachment 201801 [details]
Update to version 1.16.0 including fix for python bug + add missing dependencies
This update to the latest lv2 version should fix the python issue with python 3.7 according to the release notes.
Furthermore I added additional dependencies (fontconfig, freetype, pango) for the example plugins.