Bug 235231 - textproc/gsed 4.7: Doesn't build: makeinfo: Removing output file `./doc/sed.info' due to errors; use --force to preserve.
Summary: textproc/gsed 4.7: Doesn't build: makeinfo: Removing output file `./doc/sed.i...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Johan van Selst
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-27 08:10 UTC by Vladimir Omelchuk
Modified: 2019-02-15 21:06 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (johans)


Attachments
Full log (58.91 KB, text/plain)
2019-01-27 08:10 UTC, Vladimir Omelchuk
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Omelchuk 2019-01-27 08:10:04 UTC
Created attachment 201431 [details]
Full log

Part of log:
[…]
Making all in .
restore=: && backupdir=".am$$" &&  am__cwd=`pwd` && CDPATH="${ZSH_VERSION+.}:" && cd . &&  rm -rf $backupdir && mkdir $backupdir &&  if (/usr/bin/makeinfo --no-split --version) >/dev/null 2>&1; then  for f in ./doc/sed.info ./doc/sed.info-[0-9] ./doc/sed.info-[0-9][0-9] ./doc/sed.i[0-9] ./doc/sed.i[0-9][0-9]; do  if test -f $f; then mv $f $backupdir; restore=mv; else :; fi;  done;  else :; fi &&  cd "$am__cwd";  if /usr/bin/makeinfo --no-split   -I doc -I ./doc  -o ./doc/sed.info ./doc/sed.texi;  then  rc=0;  CDPATH="${ZSH_VERSION+.}:" && cd .;  else  rc=$?;  CDPATH="${ZSH_VERSION+.}:" && cd . &&  $restore $backupdir/* `echo "././doc/sed.info" | sed 's|[^/]*$||'`;  fi;  rm -rf $backupdir; exit $rc
./doc/sed.texi:744: warning: unlikely character [ in @var.
./doc/sed.texi:744: warning: unlikely character ] in @var.
./doc/sed.texi:747: warning: unlikely character [ in @var.
./doc/sed.texi:747: warning: unlikely character ] in @var.
./doc/sed.texi:762: warning: unlikely character [ in @var.
./doc/sed.texi:762: warning: unlikely character ] in @var.
./doc/sed.texi:779: warning: unlikely character [ in @var.
./doc/sed.texi:779: warning: unlikely character ] in @var.
./doc/sed.texi:3393: Unknown command `U'.
./doc/sed.texi:3393: Misplaced {.
./doc/sed.texi:3393: Misplaced }.
./doc/sed.texi:3406: Unknown command `U'.
./doc/sed.texi:3406: Misplaced {.
./doc/sed.texi:3406: Misplaced }.
./doc/sed.texi:3438: Unknown command `U'.
./doc/sed.texi:3438: Misplaced {.
./doc/sed.texi:3438: Misplaced }.
./doc/sed.texi:3446: Unknown command `U'.
./doc/sed.texi:3446: Misplaced {.
./doc/sed.texi:3446: Misplaced }.
./doc/sed.texi:3449: Unknown command `U'.
./doc/sed.texi:3449: Misplaced {.
./doc/sed.texi:3449: Misplaced }.
./doc/sed.texi:3533: Unknown command `U'.
./doc/sed.texi:3533: Misplaced {.
./doc/sed.texi:3533: Misplaced }.
./doc/sed.texi:3533: Unknown command `U'.
./doc/sed.texi:3533: Misplaced {.
./doc/sed.texi:3533: Misplaced }.
./doc/sed.texi:3534: Unknown command `U'.
./doc/sed.texi:3534: Misplaced {.
./doc/sed.texi:3534: Misplaced }.
./doc/sed.texi:3570: Unknown command `U'.
./doc/sed.texi:3570: Misplaced {.
./doc/sed.texi:3570: Misplaced }.
./doc/sed.texi:3573: Unknown command `U'.
./doc/sed.texi:3573: Misplaced {.
./doc/sed.texi:3573: Misplaced }.
./doc/sed.texi:3823: warning: `.' or `,' must follow @xref, not `a'.
./doc/sed.texi:3846: warning: unlikely character [ in @var.
./doc/sed.texi:3846: warning: unlikely character ] in @var.
./doc/sed.texi:4154: warning: `.' or `,' must follow @xref, not `a'.
./doc/sed.texi:4724: warning: `.' or `,' must follow @xref, not `a'.
makeinfo: Removing output file `./doc/sed.info' due to errors; use --force to preserve.
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/textproc/gsed/work/sed-4.7
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/textproc/gsed/work/sed-4.7
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/textproc/gsed/work/sed-4.7
*** Error code 1

Stop.

<uname>
FreeBSD 11.2-RELEASE-p8 amd64
Comment 1 Chris Collins 2019-02-07 04:53:49 UTC
I confirm the bug.
Comment 2 Jiri Lazansky 2019-02-14 09:55:04 UTC
(In reply to Vladimir Omelchuk from comment #0)
I was suffering from the same problem.

Later on I discovered /usr/bin/makeinfo executable that comes from older version of FreeBSD (9.x ???). After installing package texinfo and removing the obsolete /usr/bin/*info executables, the gsed 4.7 builds correctly.
Comment 3 Vladimir Omelchuk 2019-02-15 19:45:40 UTC
(In reply to Jiri Lazansky from comment #2)

Hint is working!
Thanks!
Comment 4 Vladimir Omelchuk 2019-02-15 19:47:11 UTC
PR can be closed.
Comment 5 Chris Collins 2019-02-15 20:14:29 UTC
I might open a bug for make delete-old as I definitely ran that after going from 9.x to 10.x and then again from 10.x to 11.x yet I have the binary.

Thanks for working it out.
Comment 6 Walter Schwarzenfeld freebsd_triage 2019-02-15 20:16:21 UTC
See comment 2 and  4. Close with "not a bug".
Comment 7 Vladimir Omelchuk 2019-02-15 20:35:13 UTC
(In reply to w.schwarzenfeld from comment #6)

No, this is bug!!!
Comment 8 Vladimir Omelchuk 2019-02-15 20:39:42 UTC
(In reply to w.schwarzenfeld from comment #6)

file /usr/bin/makeinfo stayed from version 10.3 ...
Comment 9 Walter Schwarzenfeld freebsd_triage 2019-02-15 20:55:56 UTC
Should I reopen, or only change the Status.
Comment 10 Vladimir Omelchuk 2019-02-15 20:58:54 UTC
(In reply to w.schwarzenfeld from comment #9)

Just change the status, please ... :)
Thanks!