Bug 235292 - math/libpgmath: 'make describe' displays warning messages
Summary: math/libpgmath: 'make describe' displays warning messages
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Johannes M Dieterich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-29 10:03 UTC by Yasuhiro KIMURA
Modified: 2019-02-03 00:56 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (jmd)


Attachments
patch file (324 bytes, patch)
2019-01-30 03:36 UTC, Yasuhiro KIMURA
yasu: maintainer-approval? (jmd)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro KIMURA 2019-01-29 10:03:45 UTC
With ports r491533 'make describe' displays warning messages as
following.

yasu@eastasia[2110]% uname -a
FreeBSD eastasia.home.utahime.org 12.0-RELEASE-p2 FreeBSD 12.0-RELEASE-p2 r342900 GENERIC  amd64
yasu@eastasia[2111]% pwd
/usr/ports/math/libpgmath
yasu@eastasia[2112]% svnversion
491533
yasu@eastasia[2113]% make describe
sh: /usr/local/llvm60/bin/clang: not found
make: "/usr0/freebsd/ports/head/Mk/Uses/compiler.mk" line 78: warning: "/usr/local/llvm60/bin/clang --version" returned non-zero status
make: "/usr0/freebsd/ports/head/Mk/Uses/compiler.mk" line 133: warning: "/usr/local/llvm60/bin/clang++ -### /dev/null 2>&1" returned non-zero status
libpgmath-g20180904_2|/usr0/freebsd/ports/head/math/libpgmath|/usr/local|Compiler-callable math intrinsics library|/usr0/freebsd/ports/head/math/libpgmath/pkg-descr|jmd@FreeBSD.org|math||||/usr0/freebsd/ports/head/devel/cmake /usr0/freebsd/ports/head/devel/llvm60 /usr0/freebsd/ports/head/devel/ninja|/usr0/freebsd/ports/head/devel/llvm60|https://github.com/flang-compiler/flang
yasu@eastasia[2114]%
Comment 1 Tobias Kortkamp freebsd_committer 2019-01-29 17:32:49 UTC
Yes, the port has USES=compiler:c++11-lib but sets CC and CXX on its own
since ports r491451.  USES=compiler:c++11-lib should probably be removed
now to fix this.
Comment 2 Yasuhiro KIMURA 2019-01-30 03:36:03 UTC
Created attachment 201518 [details]
patch file

(In reply to Tobias Kortkamp from comment #1)

Thank you for suggestion. With attached patch warning message disappeared. I also confirmed that patched port can be build successfully with poudriere and 12.0-RELEASE amd64 jail.
Comment 3 commit-hook freebsd_committer 2019-02-03 00:55:22 UTC
A commit references this bug:

Author: jmd
Date: Sun Feb  3 00:54:28 UTC 2019
New revision: 492021
URL: https://svnweb.freebsd.org/changeset/ports/492021

Log:
  math/libpgmath: remove superfluous c++11-lib requirement

  CC/CXX are explicitly set now. Unbreaks make describe.

  PR:		235292
  Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>

Changes:
  head/math/libpgmath/Makefile
Comment 4 Johannes M Dieterich freebsd_committer 2019-02-03 00:56:45 UTC
Committed, thank you!