Bug 235766 - pw(8) return "pw: user 'rundeck' disappeared during update"
Summary: pw(8) return "pw: user 'rundeck' disappeared during update"
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 12.0-RELEASE
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
Depends on:
Reported: 2019-02-15 20:01 UTC by Christoph Schönweiler
Modified: 2020-10-29 04:43 UTC (History)
3 users (show)

See Also:
arcade: maintainer-feedback+


Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Schönweiler 2019-02-15 20:01:51 UTC
Currently I'm having the same behaviour like the bug #212605. It occured while installing the sysutils/rundeck port. It blocks the installation.

[26/26] Installing rundeck-2.11.8...
===> Creating groups.
Creating group 'rundeck' with gid '819'.
===> Creating users
Creating user 'rundeck' with uid '819'.
pw: user 'rundeck' disappeared during update
install: unknown user rundeck
pkg: PRE-INSTALL script failed

If I tried to create the user with the command as the port, the error is the same.

# /usr/sbin/pw useradd rundeck -u 819 -g 819 -c "Rundeck" -d /usr/local/rundeck -s /bin/sh
pw: user 'rundeck' disappeared during update

Did you need any additional information?
Comment 1 ranvel 2019-02-16 15:42:02 UTC
This is also happening to me. I've tried several usernames ('ranvel', for example).
Comment 2 ranvel 2019-02-16 16:30:57 UTC
I don't know if this will help with your issue, but it fixed mine...

I was able to run this: 
`pwd_mkdb -p  /etc/master.passwd` 

Which updated the password database and then I was able to properly remove and then re-add the user.
Comment 3 Volodymyr Kostyrko 2019-10-09 10:13:20 UTC
Is this bug still relevant? It looks like not a problem with the port according to bug #212605.
Comment 4 Teran McKinney 2020-10-29 03:25:22 UTC
I'm getting this on two Vultr VPSs which I upgraded from 12.1-RELEASE to 12.2-RELEASE. Not seeing it on a fresh 12.2-RELEASE install.
Comment 5 Teran McKinney 2020-10-29 03:56:46 UTC
Running this once seems to resolve the issue and new accounts show up just fine.

pwd_mkdb -p  /etc/master.passwd
Comment 6 Teran McKinney 2020-10-29 04:43:16 UTC
I think that bug #232921 is more relevant to my issue, I will mention it there.