Bug 236482 - x11-fonts/mkfontscale: mkfontscale-1.2.0 conflicts with mkfontdir-1.0.7
Summary: x11-fonts/mkfontscale: mkfontscale-1.2.0 conflicts with mkfontdir-1.0.7
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-12 08:10 UTC by Davide Gessa
Modified: 2019-03-13 10:35 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Gessa 2019-03-12 08:10:11 UTC
During updating, new ports version (various fonts) requires to install mkfontscale which conflicts with mkfontdir; I can't remove mkfontdir since it's required by several other packages.

dakk /usr/ports/x11-fonts/mkfontscale sudo make install clean
===>  Installing for mkfontscale-1.2.0
===>  Checking if mkfontscale is already installed
===>   Registering installation for mkfontscale-1.2.0
Installing mkfontscale-1.2.0...
pkg-static: mkfontscale-1.2.0 conflicts with mkfontdir-1.0.7 (installs files into the same place).  Problematic file: /usr/local/bin/mkfontdir
Comment 1 Jack 2019-03-12 08:56:41 UTC
There's a comment in /usr/ports/UPDATING about this

20190311:
  AFFECTS: users of x11/xorg, x11-fonts/mkfontscale, x11-fonts/mkfontdir
  AUTHOR: zeising@FreeBSD.org

  The x11-fonts/mkfontdir port has been removed and the functionality
  has been merged into x11-fonts/mkfontscale.  This might cause issues
  with upgrading.  If you get conflicts between mkfontscale and mkfontdir
  please remove mkfontdir before upgrading.

  To do this, simply run the following:
      pkg delete -f mkfontdir
Comment 2 Davide Gessa 2019-03-12 09:14:41 UTC
(In reply to xxjack12xx from comment #1)

my bad, I didn't know about the /usr/ports/UPDATING file (first week on freebsd)
Comment 3 Niclas Zeising freebsd_committer 2019-03-13 10:35:43 UTC
I also sent mail to both the x11@ and ports@ mailing list.