Bug 236606 - graphics/graphviz: Requires CONFIGURE_ARGS+= --with-qt=no
Summary: graphics/graphviz: Requires CONFIGURE_ARGS+= --with-qt=no
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-03-17 17:52 UTC by rkoberman
Modified: 2019-03-18 14:55 UTC (History)
0 users

See Also:
dinoex: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rkoberman 2019-03-17 17:52:12 UTC
By default, graphviz will look for the presence of Qt4 and will build --with-qt if Qt4 is found. As a result, it will fail to build when qt4 libraries are present. I have a critical requirement for qt4, so will not be deleting it until that requirement is resolved.

Those who still need qt4 and/or have not deleted it can't install graphviz-2.40.1_8. This may be fixed either by patching the configure script to default to "--with-qt=no" or by adding CONFIGURE_ARGS+= --with-qt=no to Makefile.
Comment 1 Dirk Meyer freebsd_committer 2019-03-18 11:17:08 UTC
Thanks the Qt4 removal from r496028 broke it.
Comment 2 commit-hook freebsd_committer 2019-03-18 14:55:06 UTC
A commit references this bug:

Author: dinoex
Date: Mon Mar 18 14:54:20 UTC 2019
New revision: 496146
URL: https://svnweb.freebsd.org/changeset/ports/496146

Log:
  - fix bug from r496028
  PR:		236606

Changes:
  head/graphics/graphviz/Makefile