Bug 237077 - possible race in build: /usr/src/sys/amd64/linux/linux_support.s:38:2: error: expected relocatable expression
Summary: possible race in build: /usr/src/sys/amd64/linux/linux_support.s:38:2: error:...
Status: Closed DUPLICATE of bug 233339
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-emulation mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-07 18:04 UTC by Li-Wen Hsu
Modified: 2019-08-19 21:20 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Li-Wen Hsu freebsd_committer 2019-04-07 18:04:23 UTC
In some rare cases, we hit following error:

cc -target x86_64-unknown-freebsd13.0 --sysroot=/usr/obj/usr/src/amd64.amd64/tmp -B/usr/obj/usr/src/amd64.amd64/tmp/usr/bin -c -x assembler-with-cpp -DLOCORE -O2 -pipe  -fno-strict-aliasing -Werror -D_KERNEL -DKLD_MODULE -DKLD_TIED -nostdinc   -DHAVE_KERNEL_OPTION_HEADERS -include /usr/obj/usr/src/amd64.amd64/sys/GENERIC/opt_global.h -I. -I/usr/src/sys -I/usr/src/sys/contrib/ck/include -fno-common -g -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer -I/usr/obj/usr/src/amd64.amd64/sys/GENERIC    -mcmodel=kernel -mno-red-zone -mno-mmx -mno-sse -msoft-float  -fno-asynchronous-unwind-tables -ffreestanding -fwrapv -fstack-protector -gdwarf-2 -Wall -Wredundant-decls -Wnested-externs -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith -Wcast-qual -Wundef -Wno-pointer-sign -D__printf__=__freebsd_kprintf__ -Wmissing-include-dirs -fdiagnostics-show-option -Wno-unknown-pragmas -Wno-error-tautological-compare -Wno-error-empty-body -Wno-error-parentheses-equality -Wno-error-unused-function -Wno-error-pointer-sign -Wno-error-shift-negative-value -Wno-address-of-packed-member  -mno-aes -mno-avx  -std=iso9899:1999  /usr/src/sys/amd64/linux/linux_support.s -o linux_support.o
/usr/src/sys/amd64/linux/linux_support.s:38:2: error: expected relocatable expression
 movl $-EFAULT,%eax
 ^

Sample build logs:
https://ci.freebsd.org/job/FreeBSD-head-amd64-build/10679/console
https://ci.freebsd.org/job/FreeBSD-stable-12-amd64-build/825/console
Comment 1 Ed Maste freebsd_committer 2019-04-08 12:42:20 UTC
Maybe this is responsible?

14:30:48 --- linux_assym.h ---
14:30:48 sh /usr/src/sys/kern/genassym.sh linux_genassym.o > linux_assym.h

14:30:48 --- all_subdir_linux64 ---
14:30:48 /usr/src/sys/amd64/linux/linux_support.s:38:2: error: expected relocatable expression
14:30:48  movl $-EFAULT,%eax
14:30:48  ^
Comment 2 Mark Johnston freebsd_committer 2019-08-14 23:14:35 UTC
Wasn't this fixed by r345351?  I think it is a dup of bug 233339.
Comment 3 Li-Wen Hsu freebsd_committer 2019-08-19 21:20:47 UTC

*** This bug has been marked as a duplicate of bug 233339 ***