Bug 237472 - emulators/virtualbox-ose: no sound
Summary: emulators/virtualbox-ose: no sound
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: vbox
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-22 14:16 UTC by Martin Birgmeier
Modified: 2019-04-29 15:46 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (vbox)


Attachments
port option changes to enable PULSEAUDIO (6.33 KB, patch)
2019-04-22 14:16 UTC, Martin Birgmeier
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Birgmeier 2019-04-22 14:16:44 UTC
Created attachment 203898 [details]
port option changes to enable PULSEAUDIO

I have not had working sound in VirtualBox for a long time.

Scenario:
- Host OS: FreeBSD 12.0-RELEASE-p3 #6 r343805M
- Host HW: Core i7 2630QM, Conexant CX20590
- x11/kde5 installed, all ports latest
- Various client machines (Win 10, FreeBSD 12 & 13, openSUSE, Debian, CentOS,...)
- Today I recompiled all ports with PULSEAUDIO enabled (where it was off before), to be exact the following: kde5-5.15.4.19.04.0 virtualbox-ose-5.2.26_4 alsa-plugins-1.1.1_4 kmix-19.04.0 openal-soft-1.19.1_2 ffmpeg-4.1.3_2,1 mplayer-1.3.0.20190329_1 mpv-0.29.1_6,1 phonon-qt5-4.10.2_3 qt5-multimedia-5.12.2 QtAV-1.12.0_7 speech-dispatcher-0.8.8 espeak-1.48.04_6 libao-1.2.0_4 sdl-1.2.15_13,2 sdl2-2.0.9_2 vlc-3.0.6_12,4 freerdp-2.0.0.r4_2 plasma5-plasma-desktop-5.15.4_1 plasma5-plasma-5.15.4 qt5-webengine-5.12.2 (precise list of changes attached)
- VirtualBox now supports Pulseaudio, Alsa, and OSS

Result:
- Sound in the VM basically never works
- Tried with OSS, Alsa, and Pulseaudio backends
- Today, and only once, sound worked haltingly in openSUSE Leap 15.0 when using Pulseaudio (now it does not anymore)

Note:
- Sound from native applications works without problem
- A few years ago, sound did work. I believe the last VirtualBox version where it was working was something like 4.0.8.

Just curious:
- Since enabling PULSEAUDIO (see above) I now have two audio volume mixers in my panel. Can anybody explain what is going on?
- Does anybody have sound working in VirtualBox clients? If yes, what magic are you using?

-- Martin
Comment 1 Graham Perrin 2019-04-28 22:17:27 UTC
See bug 233301 – emulators/virtualbox-ose - multimedia issues on 13-current
Comment 2 Martin Birgmeier 2019-04-29 15:46:49 UTC
(In reply to Graham Perrin from comment #1)

Thank you, yes I have seen that PR.

For me not even pulseaudio works (except for exactly one time), and I did switch to it in the VM config.

-- Martin