Bug 237751 - science/hdf5: Add PARALLEL option
Summary: science/hdf5: Add PARALLEL option
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
: 225071 226912 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-04 22:44 UTC by Yuri Victorovich
Modified: 2019-10-01 18:09 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments
patch (5.28 KB, patch)
2019-05-04 22:44 UTC, Yuri Victorovich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2019-05-04 22:44:41 UTC
Created attachment 204221 [details]
patch

The project supports 'parallel' option that is unfortunately incompatible with the 'cxx' option.

This patch:
* Adds the PARALLEL option
* Adds the CXX option (that was before "on" by default)
* Updates pkg-plist

I verified that plist is correct with default options, and with CXX=off/PARALLEL=on.

Ideally PARALLEL should be a subpackage, bug subpackages aren't yet supported, and there is also the issue of cxx/parallel incompatibility.
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-08-31 11:52:20 UTC
I made minor modification. Could you please try https://people.FreeBSD.org/~sunpoet/patch/science-hdf5.txt ?
Thanks!
Comment 2 commit-hook freebsd_committer 2019-09-30 11:32:14 UTC
A commit references this bug:

Author: sunpoet
Date: Mon Sep 30 11:32:05 UTC 2019
New revision: 513366
URL: https://svnweb.freebsd.org/changeset/ports/513366

Log:
  Add PARALLEL option

  PR:		237751
  Submitted by:	yuri

Changes:
  head/science/hdf5/Makefile
  head/science/hdf5/pkg-plist
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-09-30 12:09:00 UTC
Committed. Thanks!
Comment 4 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-10-01 18:09:26 UTC
*** Bug 226912 has been marked as a duplicate of this bug. ***
Comment 5 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-10-01 18:09:29 UTC
*** Bug 225071 has been marked as a duplicate of this bug. ***