Bug 238055 - sysutils/py-salt: gitfs module broken with most recent pygit2 [patch referenced]
Summary: sysutils/py-salt: gitfs module broken with most recent pygit2 [patch referenced]
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-05-22 19:58 UTC by philipp.maechler
Modified: 2020-03-07 04:21 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description philipp.maechler 2019-05-22 19:58:59 UTC
With the most recent pygit2 module, saltstack fails to use any gitfs ressources.

The patch is already present upstream (at least for 2018.3, but I need it for 2019.2), please include it into the port until then:

[1] https://patch-diff.githubusercontent.com/raw/saltstack/salt/pull/51304.patch

further ref: 
[2] https://github.com/saltstack/salt/pull/51304
[3] https://github.com/saltstack/salt/issues/51270#issuecomment-480521624

The mentioned patch [1] worked and fixed my problem as described in the issue referenced from the pull request [2].

Root cause is in pygit2 0.27.4 according to [3].
Comment 1 philipp.maechler 2019-08-28 19:48:51 UTC
(for having the patch from [1] working, you need to do meta things:
* remove mail-header etc, remove first 12 lines
* and remove a/ and b/ from the resulting line 1 and 2)
Comment 2 Ben Woods freebsd_committer 2020-03-07 04:21:13 UTC
Hi Philipp,

Thanks for the report, and sorry no-one acted on it until now. It looks like this is now overcome by events.

Closing this bug, as this patch was introduced upstream in salt v2019.2.1.

The ports tree was updated in October 2019 to introduce salt v2019.2.2.