Bug 238431 - www/guacamole-client: Switch to newer tomcat?
Summary: www/guacamole-client: Switch to newer tomcat?
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Richard Gallamore
URL:
Keywords: needs-patch
Depends on:
Blocks: 230326
  Show dependency treegraph
 
Reported: 2019-06-09 04:11 UTC by Tobias Kortkamp
Modified: 2019-06-09 17:05 UTC (History)
0 users

See Also:
ultima: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2019-06-09 04:11:23 UTC
www/tomcat8 has been EoL for over a year and has finally been deprecated with
an expiration date of 2019-06-30.  www/guacamole-client depends on it and
the TOMCAT option might be marked broken after that point.  Can it be switched
over to one of the newer www/tomcat* ports, www/tomcat85 or www/tomcat9 ?
Comment 1 Richard Gallamore freebsd_committer 2019-06-09 04:43:41 UTC
Didn't realize tomcat8 was EOL. Will get started with testing newer versions.
Comment 2 commit-hook freebsd_committer 2019-06-09 17:04:50 UTC
A commit references this bug:

Author: ultima
Date: Sun Jun  9 17:03:58 UTC 2019
New revision: 503846
URL: https://svnweb.freebsd.org/changeset/ports/503846

Log:
  Updated tomcat to version 9 due to being EOL

  PR:		238431

Changes:
  head/www/guacamole-client/Makefile
  head/www/guacamole-client/pkg-plist