Bug 238434 - net-mgmt/cacti: Update to 1.2.5
Summary: net-mgmt/cacti: Update to 1.2.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kai Knoblich
URL: https://bugs.freebsd.org/bugzilla/sho...
Keywords:
: 239578 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-06-09 12:30 UTC by Matthew Horan
Modified: 2019-08-24 05:55 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (freebsd-ports)
kai: merge-quarterly+


Attachments
update to 1.2.5 (201.80 KB, patch)
2019-07-26 05:36 UTC, Michael Muenz
no flags Details | Diff
cacti-1.2.5_3.diff (24.16 KB, patch)
2019-08-19 10:25 UTC, Kai Knoblich
kai: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Horan 2019-06-09 12:30:56 UTC
There is a new upstream Cacti version available, 1.2.4. I worked with the upstream maintainers to incorporate changes related to the current port option SNMPBIN into Cacti. The upstream changes are a more complete implementation of the ability to disable the built-in PHP-SNMP module, and can be enabled via a configuration option $php_snmp_support = false; added to config.php.

The SNMPBIN option is no longer necessary, since the same functionality is now more completely implemented in Cacti itself (the SNMPBIN option still fell back to the PHP-SNMP module in some cases.) As a stopgap, the SNMPBIN option could be modified to display a deprecation warning and change the default value of $php_snmp_support to true.

I also propose that the dependency on the PHP-SNMP module be made optional. I do not need the PHP-SNMP module for any other packages on my system, and had to work with the upstream maintainers to introduce the $php_snmp_support option because the port insisted on installing the module. If the module were not mandatory (and indeed it is not required by Cacti itself), then I would not have needed to force disable the PHP-SNMP module.

I understand that not all users have full control of their environment, or may have other ports installed that require the PHP-SNMP option, hence introducing the new configuration option.

Thanks!
Comment 1 Michael Muenz 2019-07-26 05:35:57 UTC
Hi,

Any progress here? 
I have a finished diff for update to 1.2.5 with changes Matthew mentioned.
Comment 2 Michael Muenz 2019-07-26 05:36:33 UTC
Created attachment 206076 [details]
update to 1.2.5
Comment 3 Kai Knoblich freebsd_committer 2019-08-19 10:20:28 UTC
*** Bug 239578 has been marked as a duplicate of this bug. ***
Comment 4 Kai Knoblich freebsd_committer 2019-08-19 10:25:33 UTC
Created attachment 206696 [details]
cacti-1.2.5_3.diff

Attached the latest diff from bug #239578 (that has been marked as duplicate).
Comment 5 commit-hook freebsd_committer 2019-08-19 20:26:04 UTC
A commit references this bug:

Author: kai
Date: Mon Aug 19 20:25:29 UTC 2019
New revision: 509310
URL: https://svnweb.freebsd.org/changeset/ports/509310

Log:
  net-mgmt/cacti: Update to 1.2.5

  * Remove the SNMPBIN option that was introduced with r490477 and which is no
    longer required since the 1.2.4 release.

    It was used as a workaround to override the internal PHP SNMP calls which
    led to graphs that didn't update within cacti.

    The PHP SNMP extension can now be enabled/disabled by a re-purposed
    variable in the configuration file.

  While I'm here:

  * Remove superfluous "+=" from PLIST_SUB and SUB_LIST because there are no
    previous definitions of those variables.

  * Remove CONFLICTS_INSTALL as net-mgmt/cacti88 is no longer present in the
    Ports tree since the end of 2018.

  Changes since 1.2.3:

  https://github.com/Cacti/cacti/blob/release/1.2.5/CHANGELOG

  PR:		238434
  Submitted by:	Michael Muenz <m.muenz@gmail.com>
  Reported by:	Matthew Horan <matt@matthoran.com>
  Approved by:	maintainer timeout (2+ months)
  MFH:		2019Q3

Changes:
  head/net-mgmt/cacti/Makefile
  head/net-mgmt/cacti/distinfo
  head/net-mgmt/cacti/files/extra-patch-lib_snmp.php
  head/net-mgmt/cacti/files/patch-install__functions.php
  head/net-mgmt/cacti/files/patch-lib_installer.php
  head/net-mgmt/cacti/files/pkg-message.in
  head/net-mgmt/cacti/pkg-plist
Comment 6 Kai Knoblich freebsd_committer 2019-08-19 20:29:16 UTC
Comment on attachment 206696 [details]
cacti-1.2.5_3.diff

Approved by: maintainer timeout (+2 months this PR, +2 weeks from duplicate bug #239578)
Comment 7 Kai Knoblich freebsd_committer 2019-08-19 20:31:27 UTC
Committed to the head branch, thank you for reporting and the change at upstream, Matthew! Thanks also to Michael for submitting the patch for the Ports tree!

Still waiting for approval from the ports-secteam to commit the changes to the 2019Q3 branch.
Comment 8 commit-hook freebsd_committer 2019-08-21 07:48:03 UTC
A commit references this bug:

Author: kai
Date: Wed Aug 21 07:47:45 UTC 2019
New revision: 509495
URL: https://svnweb.freebsd.org/changeset/ports/509495

Log:
  MFH: r509310

  net-mgmt/cacti: Update to 1.2.5

  * Remove the SNMPBIN option that was introduced with r490477 and which is no
    longer required since the 1.2.4 release.

    It was used as a workaround to override the internal PHP SNMP calls which
    led to graphs that didn't update within cacti.

    The PHP SNMP extension can now be enabled/disabled by a re-purposed
    variable in the configuration file.

  While I'm here:

  * Remove superfluous "+=" from PLIST_SUB and SUB_LIST because there are no
    previous definitions of those variables.

  * Remove CONFLICTS_INSTALL as net-mgmt/cacti88 is no longer present in the
    Ports tree since the end of 2018.

  Changes since 1.2.3:

  https://github.com/Cacti/cacti/blob/release/1.2.5/CHANGELOG

  * Merge the UCL convertions from r508903 while I'm here.

  PR:		238434
  Submitted by:	Michael Muenz <m.muenz@gmail.com>
  Reported by:	Matthew Horan <matt@matthoran.com>
  Approved by:	maintainer timeout (2+ months)
  Approved by:	ports-secteam (joneum)

Changes:
_U  branches/2019Q3/
  branches/2019Q3/net-mgmt/cacti/Makefile
  branches/2019Q3/net-mgmt/cacti/distinfo
  branches/2019Q3/net-mgmt/cacti/files/extra-patch-lib_snmp.php
  branches/2019Q3/net-mgmt/cacti/files/patch-install__functions.php
  branches/2019Q3/net-mgmt/cacti/files/patch-lib_installer.php
  branches/2019Q3/net-mgmt/cacti/files/pkg-message.in
  branches/2019Q3/net-mgmt/cacti/pkg-plist
Comment 9 Kai Knoblich freebsd_committer 2019-08-21 07:52:14 UTC
Committed to the 2019Q3 branch, all done!
Comment 10 Michael Muenz 2019-08-24 05:55:14 UTC
Thanks for your time you all investigated, great community effort :)