Bug 238871 - www/webkit2-gtk3: Taints make environment for cascaded dependency builds
Summary: www/webkit2-gtk3: Taints make environment for cascaded dependency builds
Status: Closed DUPLICATE of bug 233723
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-28 20:28 UTC by chadf
Modified: 2019-07-05 09:57 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chadf 2019-06-28 20:28:33 UTC
Attempting to build webkit2-gtk3 fails on dependencies due to python mismatch from inherited settings specific to this package.

# make
===>   webkit2-gtk3-2.24.0_1 depends on package: geoclue>=2.4.3 - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/bin/ruby25 - found
===>   webkit2-gtk3-2.24.0_1 depends on executable: bison - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/bin/cmake - found
===>   webkit2-gtk3-2.24.0_1 depends on executable: ninja - found
===>   webkit2-gtk3-2.24.0_1 depends on executable: msgfmt - found
===>   webkit2-gtk3-2.24.0_1 depends on executable: g-ir-scanner - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/bin/gperf - found
===>   webkit2-gtk3-2.24.0_1 depends on package: pkgconf>=1.3.0_1 - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/bin/python2.7 - found
===>   webkit2-gtk3-2.24.0_1 depends on package: xorgproto>=0 - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xcomposite.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xdamage.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xext.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xrender.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xt.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/ice.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on package: gstreamer1-plugins-bad>=1.4 - not found
===>   gstreamer1-plugins-bad-1.14.4 depends on package: gstreamer1-plugins>=1.4.0 - not found
===>   gstreamer1-plugins-1.14.4_1 depends on package: gstreamer1>=1.4.0 - found
===>   gstreamer1-plugins-1.14.4_1 depends on package: iso-codes>=0 - not found
===>  iso-codes-4.2 needs Python 3.4 at least, but 2.7 was specified.
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/misc/iso-codes
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/multimedia/gstreamer1-plugins
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/multimedia/gstreamer1-plugins-bad
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/webkit2-gtk3
*** Error code 1

Stop.
make: stopped in /usr/ports/www/webkit2-gtk3

# pkg info 'python*'
python27-2.7.16_1
python36-3.6.8_2


If misc/iso-codes is built/installed directly, it still fails on another dependency:

# make
===>   webkit2-gtk3-2.24.0_1 depends on package: geoclue>=2.4.3 - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/bin/ruby25 - found
===>   webkit2-gtk3-2.24.0_1 depends on executable: bison - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/bin/cmake - found
===>   webkit2-gtk3-2.24.0_1 depends on executable: ninja - found
===>   webkit2-gtk3-2.24.0_1 depends on executable: msgfmt - found
===>   webkit2-gtk3-2.24.0_1 depends on executable: g-ir-scanner - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/bin/gperf - found
===>   webkit2-gtk3-2.24.0_1 depends on package: pkgconf>=1.3.0_1 - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/bin/python2.7 - found
===>   webkit2-gtk3-2.24.0_1 depends on package: xorgproto>=0 - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xcomposite.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xdamage.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xext.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xrender.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/xt.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on file: /usr/local/libdata/pkgconfig/ice.pc - found
===>   webkit2-gtk3-2.24.0_1 depends on package: gstreamer1-plugins-bad>=1.4 - found
===>   webkit2-gtk3-2.24.0_1 depends on package: gstreamer1-plugins-gl>=1.4 - not found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on package: gstreamer1>=1.4.0 - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on package: iso-codes>=0 - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on package: orc>=0.4.16 - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on package: gstreamer1-plugins>=1.4.0 - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on file: /usr/local/include/linux/input.h - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on executable: msgfmt - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on executable: gmake - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on executable: g-ir-scanner - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on package: pkgconf>=1.3.0_1 - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on file: /usr/local/bin/python2.7 - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on package: xorgproto>=0 - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on package: xorgproto>=0 - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on package: gstreamer1-plugins>=1.4 - found
===>   gstreamer1-plugins-gl-1.14.4_2 depends on shared library: libgstreamer-1.0.so - found (/usr/local/lib/libgstreamer-1.0.so)
===>   gstreamer1-plugins-gl-1.14.4_2 depends on shared library: libfreetype.so - found (/usr/local/lib/libfreetype.so)
===>   gstreamer1-plugins-gl-1.14.4_2 depends on shared library: liborc-0.4.so - found (/usr/local/lib/liborc-0.4.so)
===>   gstreamer1-plugins-gl-1.14.4_2 depends on shared library: libwayland-egl.so - found (/usr/local/lib/libwayland-egl.so)
===>   gstreamer1-plugins-gl-1.14.4_2 depends on shared library: libgraphene-1.0.so - not found
===>  graphene-1.8.2_1 needs Python 3.4 at least, but 2.7 was specified.
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/graphics/graphene
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/graphics/gstreamer1-plugins-gl
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/graphics/gstreamer1-plugins-gl
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/webkit2-gtk3
*** Error code 1

Stop.
make: stopped in /usr/ports/www/webkit2-gtk3


# uname -a
FreeBSD myhostname 12.0-RELEASE-p6 FreeBSD 12.0-RELEASE-p6 MYKERNELNAME  amd64


I suspect it has to do with this line in the Makefile:
BINARY_ALIAS=           python=${PYTHON_CMD}


Separately building/installing graphics/gstreamer1-plugins-gl first is a work around, but is inconvenient and took trial and error to locate the source of taint (as I was initially building from a higher level package).
Comment 1 Tobias Kortkamp freebsd_committer 2019-07-05 09:57:04 UTC

*** This bug has been marked as a duplicate of bug 233723 ***