Bug 238992 - x11-toolkits/qt5-gui: Qt5 apps fail to run when installed alone into a jail
Summary: x11-toolkits/qt5-gui: Qt5 apps fail to run when installed alone into a jail
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: kde
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-04 18:14 UTC by Yuri Victorovich
Modified: 2019-07-04 19:59 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2019-07-04 18:14:12 UTC
I installed the qTox package into a jail, and it failed to run:

> [18:07:23.828 UTC] :0 : Warning: QStandardPaths: XDG_RUNTIME_DIR points to non-existing path '/var/run/user/1001', please create it with 0700 permissions.
dbus[86894]: D-Bus library appears to be incorrectly set up: see the manual page for dbus-uuidgen to correct this issue. (Failed to open "/var/lib/dbus/machine-id": No such file or directory; Failed to open "/etc/machine-id": No such file or directory)
>  D-Bus not built with -rdynamic so unable to print a backtrace


It seems like Qt5 requires the dbus service. IMO, this should be only a warning, and not a failure.

I will create the upstream bug. This bug here is to track the issue, and to invite opinions about this issue.

But Qt5 apps should not fail because some secondary library isn't initialized. DBus isn't required for most UI operations. qTox should run fine without DBus.
Comment 1 Tobias Kortkamp freebsd_committer 2019-07-04 18:18:27 UTC
This has likely nothing to do with Qt and is probably a dupe of bug #228001
Comment 2 Yuri Victorovich freebsd_committer 2019-07-04 18:22:26 UTC
(In reply to Tobias Kortkamp from comment #1)

This is likely the case. This makes all Qt apps to fail for this obscure reason.
Comment 3 Tobias C. Berner freebsd_committer 2019-07-04 18:59:17 UTC
Yuri, do you mind taking tobik's review and pushing it through?

mfg Tobias
Comment 4 Tobias C. Berner freebsd_committer 2019-07-04 19:00:59 UTC
With hat: I don't think kde@ can do anything here, apart from adding a pkg-message that you should enable dbus.

I close this therefore with an unsatisfactory "works as intended" -- please let me know if you think the pkg-message would be helpful.


mfg Tobias
Comment 5 Yuri Victorovich freebsd_committer 2019-07-04 19:59:33 UTC
(In reply to Tobias C. Berner from comment #4)

Thank you, Tobias.

I didn't realize that this is entirely a dbus issue, and was under the impression that it was somehow linked to Qt5 .

Yuri