Bug 239132 - lang/go14 build broken with aslr
Summary: lang/go14 build broken with aslr
Status: Closed DUPLICATE of bug 235735
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Julien Laffaye
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-11 03:21 UTC by Miyashita Touka
Modified: 2019-07-11 06:14 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (jlaffaye)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miyashita Touka 2019-07-11 03:21:37 UTC
The lang/go14 port does not compile with ASLR enabled.

To reproduce, run:

sysctl kern.elf64.aslr.enable=1
sysctl kern.elf64.aslr.pie_enable=1

And try to build it. Turning those off fixes the build on 12-STABLE.
Comment 1 Tobias Kortkamp freebsd_committer 2019-07-11 06:14:19 UTC

*** This bug has been marked as a duplicate of bug 235735 ***