Bug 239316 - java/openjdk8 8.222.10.1 fails to build
Summary: java/openjdk8 8.222.10.1 fails to build
Status: Closed DUPLICATE of bug 239358
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-java mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-19 19:59 UTC by VVD
Modified: 2019-07-24 23:37 UTC (History)
5 users (show)

See Also:
bugzilla: maintainer-feedback? (java)


Attachments
Fixed fontconfig.patch (7.28 KB, patch)
2019-07-20 21:52 UTC, VVD
no flags Details | Diff
[patch] fix fontconfig patch after jdk8u222 + remove unnecessary shebangfix (4.58 KB, patch)
2019-07-23 14:47 UTC, John Hein
jcfyecrayz: maintainer-approval? (frebsd-java)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2019-07-19 19:59:56 UTC
11.3 amd64.
Look like fontconfig.patch need update.
Build log:
===>  License GPLv2 accepted by the user
===>   openjdk8-8.222.10.1 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by openjdk8-8.222.10.1 for building
===>  Extracting for openjdk8-8.222.10.1
=> SHA256 Checksum OK for battleblow-openjdk-jdk8u-8.222.10.1-jdk8u222-b10.1_GH0.tar.gz.
===>  Patching for openjdk8-8.222.10.1
===>  Applying FreeBSD patches for openjdk8-8.222.10.1
No such line 970 in input file, ignoring
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- jdk/src/share/native/sun/font/freetypeScaler.c.orig        2017-01-20 17:04:07 UTC
|+++ jdk/src/share/native/sun/font/freetypeScaler.c
--------------------------
Patching file jdk/src/share/native/sun/font/freetypeScaler.c using Plan A...
Hunk #1 succeeded at 38.
Hunk #2 succeeded at 667 (offset -28 lines).
Hunk #3 failed at 822.
Hunk #4 succeeded at 876 (offset -1 lines).
Hunk #5 succeeded at 1078 (offset -28 lines).
1 out of 5 hunks failed--saving rejects to jdk/src/share/native/sun/font/freetypeScaler.c.rej
Hmm...  The next patch looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- jdk/make/lib/Awt2dLibraries.gmk.orig       2015-07-18 14:30:01.000000000 -0700
|+++ jdk/make/lib/Awt2dLibraries.gmk    2015-07-18 14:30:08.000000000 -0700
--------------------------
Patching file jdk/make/lib/Awt2dLibraries.gmk using Plan A...
Hunk #1 succeeded at 939 (offset -4 lines).
done
*** Error code 1
Comment 1 VVD 2019-07-19 20:39:01 UTC
Same on 12.0 amd64.
Comment 2 VVD 2019-07-20 21:52:34 UTC
Created attachment 205950 [details]
Fixed fontconfig.patch

Just replace file java/openjdk8/files/fontconfig.patch with this one.
Comment 3 John Hein 2019-07-23 13:10:51 UTC
See also bug 239358
Comment 4 John Hein 2019-07-23 14:47:26 UTC
Created attachment 206011 [details]
[patch] fix fontconfig patch after jdk8u222 + remove unnecessary shebangfix

Regen patch using makepatch-like patch generation.
Set fontconfig patch via EXTRA_PATCHES instead of creating a special target that does the same thing.

While here, remove unnecessary shebangfix.

(this is the same as the patch now attached in bug 239358 - one of these bugs should be closed as a DUPLICATE).
Comment 5 Greg Lewis freebsd_committer 2019-07-24 23:37:42 UTC
Duplicate of bug 239358

*** This bug has been marked as a duplicate of bug 239358 ***