Bug 239472 - devel/ghidra: Fix build error caused by cache cleanup
Summary: devel/ghidra: Fix build error caused by cache cleanup
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-27 06:46 UTC by Tamas Szakaly
Modified: 2019-08-11 14:46 UTC (History)
0 users

See Also:
tobik: merge-quarterly+


Attachments
Patch to fix build error caused by cache cleanup (520 bytes, patch)
2019-07-27 06:46 UTC, Tamas Szakaly
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tamas Szakaly 2019-07-27 06:46:42 UTC
Created attachment 206097 [details]
Patch to fix build error caused by cache cleanup

Hi all,

I've received e-mails of devel/ghidra build failures from pkg-fallout@. The issue seems to be caused by Gradle caches being cleaned up between build sessions [1]. This issue didn't came up before because the cached files were not old enough to be deleted.

Cleanup happens after a build session, so the attached patch fixes this issue by running the two build targets (yajswDevUnpack and buildGhidra) in the same session.

Cheers,
Toma


[1] https://docs.gradle.org/current/userguide/directory_layout.html#dir:gradle_user_home:cache_cleanup)
Comment 1 commit-hook freebsd_committer 2019-08-11 14:45:08 UTC
A commit references this bug:

Author: tobik
Date: Sun Aug 11 14:44:41 UTC 2019
New revision: 508626
URL: https://svnweb.freebsd.org/changeset/ports/508626

Log:
  devel/ghidra: Fix build error caused by cache cleanup

  The issue seems to be caused by Gradle caches being cleaned up
  between build sessions [1].  It did not come up before because the
  cached files were not old enough to be deleted.

  Cleanup happens after a build session, so running the two build
  targets (yajswDevUnpack and buildGhidra) in the same session fixes
  the issue.

  [1] https://docs.gradle.org/current/userguide/directory_layout.html#dir:gradle_user_home:cache_cleanup)

  PR:		239472
  Submitted by:	Tamas Szakaly <sghctoma@gmail.com> (maintainer)

Changes:
  head/devel/ghidra/Makefile
Comment 2 commit-hook freebsd_committer 2019-08-11 14:46:09 UTC
A commit references this bug:

Author: tobik
Date: Sun Aug 11 14:45:38 UTC 2019
New revision: 508627
URL: https://svnweb.freebsd.org/changeset/ports/508627

Log:
  MFH: r508626

  devel/ghidra: Fix build error caused by cache cleanup

  The issue seems to be caused by Gradle caches being cleaned up
  between build sessions [1].  It did not come up before because the
  cached files were not old enough to be deleted.

  Cleanup happens after a build session, so running the two build
  targets (yajswDevUnpack and buildGhidra) in the same session fixes
  the issue.

  [1] https://docs.gradle.org/current/userguide/directory_layout.html#dir:gradle_user_home:cache_cleanup)

  PR:		239472
  Submitted by:	Tamas Szakaly <sghctoma@gmail.com> (maintainer)

  Approved by:	ports-secteam build fix blanket

Changes:
_U  branches/2019Q3/
  branches/2019Q3/devel/ghidra/Makefile
Comment 3 Tobias Kortkamp freebsd_committer 2019-08-11 14:46:25 UTC
Committed. Thanks!