Bug 239507 - lang/spidermonkey52: fix build with GCC-based architectures
Summary: lang/spidermonkey52: fix build with GCC-based architectures
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Koop Mast
URL:
Keywords:
: 239485 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-07-29 07:51 UTC by Piotr Kubaj
Modified: 2019-08-05 13:31 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (kwm)


Attachments
patch (1.10 KB, patch)
2019-07-29 07:51 UTC, Piotr Kubaj
pkubaj: maintainer-approval? (kwm)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-07-29 07:51:37 UTC
Created attachment 206134 [details]
patch

With gcc9, build fails:
/usr/local/poudriere/ports/default/lang/spidermonkey52/work/firefox-52.9.0esr/js/src/jsapi-tests/testPrintf.cpp: In member function 'virtual bool cls_testPrintf::run(JS::HandleObject
)':
/usr/local/poudriere/ports/default/lang/spidermonkey52/work/firefox-52.9.0esr/js/src/jsapi-tests/testPrintf.cpp:58:20: error: '%s' directive argument is null [-Werror=format-overflow
=]
   58 |     CHECK(print_one("(null)", "%s", zero()));


Remove the test printf:
CHECK(print_one("(null)", "%s", zero()));
to fix build.
Comment 1 Tobias Kortkamp freebsd_committer 2019-07-29 07:54:25 UTC
*** Bug 239485 has been marked as a duplicate of this bug. ***
Comment 2 Tobias Kortkamp freebsd_committer 2019-08-02 10:16:36 UTC
Pretty sure this falls under portmgr blanket and you can just commit it
(after mentor approval).
Comment 3 commit-hook freebsd_committer 2019-08-05 13:31:00 UTC
A commit references this bug:

Author: pkubaj
Date: Mon Aug  5 13:30:39 UTC 2019
New revision: 508168
URL: https://svnweb.freebsd.org/changeset/ports/508168

Log:
  lang/spidermonkey52: fix build with GCC-based architectures

  With gcc9, build fails:
  /usr/local/poudriere/ports/default/lang/spidermonkey52/work/firefox-52.9.0esr/js/src/jsapi-tests/testPrintf.cpp: In member function 'virtual bool cls_testPrintf::run(JS::HandleObject
  )':
  /usr/local/poudriere/ports/default/lang/spidermonkey52/work/firefox-52.9.0esr/js/src/jsapi-tests/testPrintf.cpp:58:20: error: '%s' directive argument is null [-Werror=format-overflow
  =]
     58 |     CHECK(print_one("(null)", "%s", zero()));

  Remove the test printf:
  CHECK(print_one("(null)", "%s", zero()));
  to fix build.

  PR:		239507
  Approved by:	tcberner (mentor), portmgr blanket
  Differential Revision:	https://reviews.freebsd.org/D21144

Changes:
  head/lang/spidermonkey52/files/patch-js_src_jsapi-tests_testPrintf.cpp