Bug 239703 - devel/subversion: svnsync with HTTPS fails with SERF=on build option that allegedly adds HTTP/HTTPS support
Summary: devel/subversion: svnsync with HTTPS fails with SERF=on build option that all...
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Lev A. Serebryakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-07 20:18 UTC by agifford
Modified: 2019-08-07 20:18 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (lev)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description agifford 2019-08-07 20:18:07 UTC
I've had a SVN mirroring script to mirror FreeBSD's base source (for use on an internal network that doesn't have access to FreeBSD's SVN servers for soure updating), a script that's worked for ages that broke recently.  Analysis points to the devel/subversion port no longer supporting HTTPS protocol in the svnsync utility.

Here are the errors I see:

$ svn propset svn:sync-from-url --revprop -r 0 https://svn0.us-east.freebsd.org/base file:///data/svn/base
property 'svn:sync-from-url' set on repository revision 0
$ svnadmin setuuid /data/svn/base "ccf9f872-aa2e-dd11-9fc8-001c23d0bc1f"
$ svnsync sync file:///data/svn/base
svnsync: E170013: Unable to connect to a repository at URL 'https://svn0.us-east.freebsd.org/base'
svnsync: E000043: Error running context: Protocol not supported

Oddly these commands work perfectly if I use an older source-compiled version of the port, version 1.9.7.

But when I install the latest quarterly ABI pre-built package 1.12.0, it doesn't work.

So I compiled from source version 1.12.2 and installed it.  It doesn't work either (same error).

I double-checked port build options.  From the `make config` options, it looks like option SERF controls HTTP/HTTPS protocol.  So I checked my 1.12.2 source build.  SERF=on.  I checked the quarterly ABI pre-built package, 1.12.0, using `pkg query -e "%n=subversion" "%n-%v %Ok %Ov` and it showed SERF=on.  My old, WORKING 1.9.7 port also showed SERF=on.

This one has left me puzzled and frustrated.  I prefer to use HTTPS (no man-in-the-middle potential with validated certificate), and prefer to use an up-to-date port version.

THANKS in advance for any help or pointers on how to get HTTP/HTTPS support back into the svnsync utility within the devel/subversion port!

-Aaron out.

(Unrelated to this bug report tangental note: alleged FreeBSD SVN mirror svn0.us-west.freebsd.org resolves to a DNS CNAME that points to svnmir.ysv.freebsd.org which does NOT resolve, despite svn0.us-west.freebsd.org still appearing in FreeBSD's docs.)