Bug 239845 - New port: graphics/fractgen -- Fractal Generator
Summary: New port: graphics/fractgen -- Fractal Generator
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Rodrigo Osorio
URL: https://www.uni-due.de/~be0001/fracta...
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-14 11:54 UTC by dreibh
Modified: 2019-08-20 11:49 UTC (History)
1 user (show)

See Also:


Attachments
The shar file (1.90 KB, text/plain)
2019-08-14 11:54 UTC, dreibh
no flags Details
port with fixes (2.43 KB, text/plain)
2019-08-19 07:50 UTC, Rodrigo Osorio
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description dreibh 2019-08-14 11:54:14 UTC
Created attachment 206524 [details]
The shar file

The package fractgen has been missing in the FreeBSD ports. Therefore, I have created a port.

FractGen is a simple Qt-based fractal generator program for Mandelbrot fractals. The image size is only limited by virtual memory. It is possible to zoom into images. Image parameters can be saved in XML files and loaded from XML files. Calculated images can be exported as PNG files. The intention of this program is to generate graphics to be post-processed by other image tools, e.g. in order to generate nice screen backgrounds or book covers. 

Homepage of fractgen: https://www.uni-due.de/~be0001/fractalgenerator/

Fix: The shar file fractgen-2.1.7.shar is attached.
Comment 1 Rodrigo Osorio freebsd_committer 2019-08-19 07:50:57 UTC
Created attachment 206690 [details]
port with fixes

Hi,

There are a few missing elements in your port,
this version correct those few things, please try
it and let me know if the port work as intended.

Cheers,
-- rodrigo
Comment 2 dreibh 2019-08-19 19:50:35 UTC
Yes, the updated port looks fine. Thank you!
Comment 3 commit-hook freebsd_committer 2019-08-20 11:48:33 UTC
A commit references this bug:

Author: rodrigo
Date: Tue Aug 20 11:48:22 UTC 2019
New revision: 509423
URL: https://svnweb.freebsd.org/changeset/ports/509423

Log:
  New port graphics/fractgen : Fractal Generator

  FractGen is a simple Qt-based fractal generator program for Mandelbrot fractals.

  PR:		239845
  Submitted by:	Thomas Dreibholz <dreibh@iem.uni-due.de>

Changes:
  head/graphics/Makefile
  head/graphics/fractgen/
  head/graphics/fractgen/Makefile
  head/graphics/fractgen/distinfo
  head/graphics/fractgen/pkg-descr
  head/graphics/fractgen/pkg-plist
Comment 4 Rodrigo Osorio freebsd_committer 2019-08-20 11:49:10 UTC
Committed with minor changes on the pkg-descr. Thanks!