Bug 239902 - devel/ghidra: Fails to build with Gradle 5.6
Summary: devel/ghidra: Fails to build with Gradle 5.6
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL: https://people.freebsd.org/~pi/logs/g...
Keywords:
Depends on:
Blocks: 239875
  Show dependency treegraph
 
Reported: 2019-08-16 10:07 UTC by Tobias Kortkamp
Modified: 2019-08-16 11:05 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (sghctoma)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Kortkamp freebsd_committer 2019-08-16 10:07:06 UTC
FAILURE: Build failed with an exception.

* Where:
Build file '/wrkdirs/usr/ports/devel/ghidra/work/ghidra-Ghidra_9.0.4_build/build.gradle' line: 10

* What went wrong:
A problem occurred evaluating root project 'ghidra-Ghidra_9.0.4_build'.
> Requires Gradle 5.0, but was run with 5.6

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 3s
*** Error code 1

https://people.freebsd.org/~pi/logs/ghidra-9.0.4.log
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-08-16 11:05:46 UTC
 https://gitee.com/mirrors/Ghidra/raw/master/DevGuide.md
-->
* Gradle 5.0 or later - We use version 5.0, and tested with up to 5.5.1.

Seems only have to change:
work/ghidra-Ghidra_9.0.4_build/build.gradle

 9 if (gradle.gradleVersion != "5.0") {
     10         throw new GradleException("Requires Gradle 5.0, but was run with $gradle.gradleVersion")
     11 }