Bug 240262 - www/firefox: Fails to build: The 'requests>=2.0.0' distribution was not found and is required by Sphinx (arm, CURRENT @ r351586)
Summary: www/firefox: Fails to build: The 'requests>=2.0.0' distribution was not found...
Status: Open
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-09-02 00:17 UTC by Bob Prohaska
Modified: 2019-09-04 21:50 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments
pkg version -v output (3.65 KB, text/plain)
2019-09-02 20:27 UTC, Bob Prohaska
no flags Details
output of ls -la /usr/local/lib/python3.6/site-packages/ (41.32 KB, text/plain)
2019-09-02 20:28 UTC, Bob Prohaska
no flags Details
output from make (21.36 KB, text/plain)
2019-09-04 15:55 UTC, Bob Prohaska
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Prohaska 2019-09-02 00:17:54 UTC
On FreeBSD www.zefox.org 13.0-CURRENT FreeBSD 13.0-CURRENT r351586 GENERIC  arm64

www/firefox build stops with
[3455/4888] cd /usr/work/usr/ports/devel/llvm80/work/.build/tools/clang/tools/extra/docs && /usr/local/bin/cmake -E make_directory /usr/work/usr/ports/devel/llvm80/work/.build/tools/clang/tools/extra/docs/man && /usr/local/bin/sphinx-build-3.6 -b man -d /usr/work/usr/ports/devel/llvm80/work/.build/tools/clang/tools/extra/docs/_doctrees-clang-tools-man -q /usr/work/usr/ports/devel/llvm80/work/llvm-8.0.1.src/tools/clang/tools/extra/docs /usr/work/usr/ports/devel/llvm80/work/.build/tools/clang/tools/extra/docs/man
FAILED: tools/clang/tools/extra/docs/CMakeFiles/docs-clang-tools-man 
cd /usr/work/usr/ports/devel/llvm80/work/.build/tools/clang/tools/extra/docs && /usr/local/bin/cmake -E make_directory /usr/work/usr/ports/devel/llvm80/work/.build/tools/clang/tools/extra/docs/man && /usr/local/bin/sphinx-build-3.6 -b man -d /usr/work/usr/ports/devel/llvm80/work/.build/tools/clang/tools/extra/docs/_doctrees-clang-tools-man -q /usr/work/usr/ports/devel/llvm80/work/llvm-8.0.1.src/tools/clang/tools/extra/docs /usr/work/usr/ports/devel/llvm80/work/.build/tools/clang/tools/extra/docs/man
Traceback (most recent call last):
  File "/usr/local/bin/sphinx-build-3.6", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3250, in <module>
    @_call_aside
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3234, in _call_aside
    f(*args, **kwargs)
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3263, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'requests>=2.0.0' distribution was not found and is required by Sphinx
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-09-02 04:40:19 UTC
*  devel/llvm80 depends on sphinx-build-3.6 (via textproc/py-sphinx@py36)
*  textproc/py-sphinx@py36 depends on py36-requests>=2.18.1 (via www/py-requests@py36)
* www/py-requests is currently at 2.20.0 (satisfies the 2.18.1 min version requirement of sphinx)

The question is why is the 'requests' Python package not satisfied on this system

Could you please provide more information, including:

- pkg version -v output (as an attachment)
- output of ls -la /usr/local/lib/python3.6/site-packages/ (as an attachment)
- output of ls -la /usr/local/lib/python3.6/site-packages/requests (as an attachment, if it exists)
Comment 2 Bob Prohaska 2019-09-02 20:27:23 UTC
Created attachment 207123 [details]
pkg version -v output
Comment 3 Bob Prohaska 2019-09-02 20:28:34 UTC
Created attachment 207124 [details]
output of ls -la /usr/local/lib/python3.6/site-packages/
Comment 4 Bob Prohaska 2019-09-02 20:38:05 UTC
When firefox failed to build I immediately updated ports and tried www/chromium.

The attachments were prepared _after_ the update and while www/chromium was
compiling. I hope that does not obscure their significance.

Also, I've been using Stefan Esser's experimental portmaster-devel, mostly
for sake of its restart feature. If that is an impediment please say so and
I'll revert to using plain make.
Comment 5 Christoph Moench-Tegeder freebsd_committer 2019-09-02 20:46:49 UTC
Unless I'm missing something...
- this is devel/llvm80 failing, not firefox (llvm80 is a build-dependency of firefox, yes, but in this case we haven't even really started on the firefox build), so gecko might not be the right person to talk to
- despite www/py-requests being listed in the RUN_DEPENDS of textproc/py-sphinx, there is no py36-requests satisfying that dependency for py36-sphinx in your package list (there are py27-requests and py27-sphinx, but it's the python 3.6 flavor which is bombing out here, to the 2.7 packages are not helpful).

I'd guess that whatever tool you're using to manage your packages did fail to do so properly (unless you did some --force'ing and everything is on you).
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2019-09-03 02:27:32 UTC
(In reply to Bob Prohaska from comment #4)
(In reply to Christoph Moench-Tegeder from comment #5)

Certainly reproduction using plain make or portmaster (non -devel) would be handy, if nothing else than to isolate where the issue may be root caused.

That py36-requests is not installed is indeed the cause, why its not being installed is the question

I would also test another port that has sphinx and therefore requests (python 3.6 version) as a dependency.

Once isolated, we can update the issue summary to reflect where the issue is, if it is in a port, and not a local configuration problem.
Comment 7 Bob Prohaska 2019-09-03 02:46:09 UTC
Ok, I'll revert to using plain make for further experiments.

Can you suggest a good test case for sphinx? I'm totally unfamiliar with
it; on first sight I thought it had something to do with sound.
Comment 8 Bob Prohaska 2019-09-04 01:52:50 UTC
After running make clean in www/firefox I tried:

root@www:/usr/ports/www/firefox # make > make.log &
[1] 11910
root@www:/usr/ports/www/firefox # 

After the distfiles untarred again the controlling terminal reported

DEBUG: Executing: `rustup which rustc`
DEBUG: The command returned non-zero exit status 1.
DEBUG: Its error output was:
DEBUG: | error: multiple input filenames provided (first two filenames are `which` and `rustc`)
DEBUG: | 
ERROR: Command `rustup which rustc` failed with exit status 1.

There were a few complaints in the log file, for example
=> SHA256 Checksum OK for firefox-69.0.source.tar.xz.
===>  Patching for firefox-69.0,1
===>  Applying FreeBSD patches for firefox-69.0,1
No such line 323 in input file, ignoring
No such line 821 in input file, ignoring
No such line 3950 in input file, ignoring
 
But, the log file reports
checking for rustc... /usr/local/bin/rustc
checking for cargo... /usr/local/bin/cargo
===>  Script "configure" failed unexpectedly.

Any suggestions appreciated.
Comment 9 mikael.urankar 2019-09-04 10:09:46 UTC
(In reply to Bob Prohaska from comment #8)
Can you provide the full build log?
Comment 10 Walter Schwarzenfeld freebsd_triage 2019-09-04 12:19:38 UTC
(In reply to Bob Prohaska from comment #8)
"Standardtry": have you tried to reinstall py-pip and py-setuptools. Sometimes this helps with similar problems.
Comment 11 Bob Prohaska 2019-09-04 15:55:05 UTC
Created attachment 207187 [details]
output from make
Comment 12 Bob Prohaska 2019-09-04 15:57:06 UTC
I've attached the output from make. Alas, I ran a make clean afterwards
and so lost the config log mentioned in the make output. I'll try again
when the machine is free.
Comment 13 Bob Prohaska 2019-09-04 21:50:08 UTC
(In reply to Walter Schwarzenfeld from comment #10)

Haven't checked the Pi3 yet, it's busy with www/chromium. 

However, I did check a Pi2 that
failed in previous attempts to build firefox. It seems py-pip wasn't 
installed, but is installed now. Py-setuptools was installed and has
now been reinstalled. The Pi2 is now attempting to compile www/firefox.