Bug 240333 - [patch] devel/clixon upgrade to 4.1.0
Summary: [patch] devel/clixon upgrade to 4.1.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Renato Botelho
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-04 17:45 UTC by Dave Cornejo
Modified: 2019-09-04 18:00 UTC (History)
1 user (show)

See Also:


Attachments
patch to upgrade to 4.1.0 (3.05 KB, patch)
2019-09-04 17:45 UTC, Dave Cornejo
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Cornejo 2019-09-04 17:45:03 UTC
Created attachment 207191 [details]
patch to upgrade to 4.1.0

this upgrades devel/clixon to version 4.1.0

this also fixes an error in the 4.0.0 upgrade which allowed the use of an old version of the cligen library that is incompatible with clixon 4.0.0 or later.

note that cligen is still at 4.0.0.
Comment 1 commit-hook freebsd_committer 2019-09-04 18:00:20 UTC
A commit references this bug:

Author: garga
Date: Wed Sep  4 18:00:15 UTC 2019
New revision: 511144
URL: https://svnweb.freebsd.org/changeset/ports/511144

Log:
  devel/clixon: Update to 4.1.0

  - While here, make it to build with multiple jobs
  - Make it to require cligen 4.0.0 or newer

  PR:		240333
  Submitted by:	David Cornejo <dcornejo@netgate.com> (maintainer)
  Sponsored by:	Rubicon Communications, LLC (Netgate)

Changes:
  head/devel/clixon/Makefile
  head/devel/clixon/distinfo
  head/devel/clixon/files/patch-configure.ac
  head/devel/clixon/pkg-plist