Bug 240407 - print/lilypond-devel: Fix fontforge version check
Summary: print/lilypond-devel: Fix fontforge version check
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Niclas Zeising
URL:
Keywords: needs-qa
Depends on:
Blocks:
 
Reported: 2019-09-08 07:01 UTC by m.ne
Modified: 2019-09-09 16:57 UTC (History)
1 user (show)

See Also:
m.ne: maintainer-feedback+
koobs: merge-quarterly?


Attachments
fixed version check (1.62 KB, patch)
2019-09-08 07:01 UTC, m.ne
m.ne: maintainer-approval+
Details | Diff
fixed version check (1.92 KB, patch)
2019-09-08 07:42 UTC, m.ne
m.ne: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description m.ne 2019-09-08 07:01:20 UTC
Created attachment 207274 [details]
fixed version check

With the latest update to print/fontforge the version check didn't work anymore. The attached patch changes that check to extract the correct version again.
Comment 1 m.ne 2019-09-08 07:42:38 UTC
Created attachment 207275 [details]
fixed version check

removing BROKEN statement added between creating and submitting the previous patch
Comment 2 Niclas Zeising freebsd_committer 2019-09-09 16:10:00 UTC
Part of the issue is that fontforge is stupid and tries to open a GUI before parsing options, such as -version, which doesn't need a GUI.  I've submitted a RP for fontconfig for that issue.  This looks like a good interim solution, though.  There is no need to merge it to the Q3 branch, since it's only an issue after the fontforge update.
Comment 3 commit-hook freebsd_committer 2019-09-09 16:54:52 UTC
A commit references this bug:

Author: zeising
Date: Mon Sep  9 16:54:33 UTC 2019
New revision: 511648
URL: https://svnweb.freebsd.org/changeset/ports/511648

Log:
  print/lilypond-devel: Fix configure

  Fix configure script issues detecting fontforge after fontforge update.

  PR:		240407
  Submitted by:	m.ne@gmx.net (maintainer)

Changes:
  head/print/lilypond-devel/Makefile
  head/print/lilypond-devel/files/patch-configure
Comment 4 Niclas Zeising freebsd_committer 2019-09-09 16:57:30 UTC
Committed, thanks!