Bug 240647 - bhyve cannot properly use Windows (system restarts infinitely)
Summary: bhyve cannot properly use Windows (system restarts infinitely)
Status: Closed Works As Intended
Alias: None
Product: Base System
Classification: Unclassified
Component: bhyve (show other bugs)
Version: 12.0-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-virtualization mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-09-17 16:14 UTC by IPTRACE
Modified: 2019-09-18 05:56 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description IPTRACE 2019-09-17 16:14:10 UTC
Hello!

I've got an issue with using Windows (7/10 or even Server version) as a client due to auto-restart of the system. I cannot even log in because system restarts infinitely, seen at console on 5900 port.

Generally, I'm able to boot from CD/DVD (iso file). I can install Windows.
But after installation, the system loads and I can see logon screen. After half a minute or minute system shuts down and that's all.
I was trying to run ready and working system from the another machine and it's the same.

I tried this solution (Windows option change)

https://www.drivereasy.com/knowledge/windows-10-keeps-restarting-try-these-steps/

without success.
In this case I can change logon type to Safe mode, but after restart and loading the system, the issue keeps the same.

I was trying on diffrent partitions with different hard drives.
I was changing number of CPU nad RAM (on bhyve).
I disconnected virtual network card network from bhyve command as well.

FreeBSD 12.0-RELEASE-p10 amd64
Command:

# bhyve -c 4 -m 8G -H \
-s 0,hostbridge \
-s 3,ahci-hd,/data/vm12.img,sectorsize=512 \
-s 10,virtio-net,tap1 \
-s 29,fbuf,tcp=0.0.0.0:5900,wait \
-s 30,xhci,tablet \
-s 31,lpc -l bootrom,/usr/local/share/uefi-firmware/BHYVE_UEFI.fd -w vm12
Comment 1 IPTRACE 2019-09-18 05:56:39 UTC
Solved!

In my case I just disabled auto restart at Windows registry using this manual (point 3).
https://www.thewindowsclub.com/windows-10-stuck-in-endless-reboot-loop

And command line to modify registry.

https://www.windowscentral.com/how-edit-registry-using-command-prompt-windows-10

Conclusion. It's not bhyve issue.