Bug 241151 - x11/lightdm becomes very slow under 12.1-BETA3
Summary: x11/lightdm becomes very slow under 12.1-BETA3
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Ben Woods
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-09 10:15 UTC by Vincent DEFERT
Modified: 2019-10-10 10:04 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (woodsb02)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent DEFERT 2019-10-09 10:15:58 UTC
I'm using LightDM in conjuction with MATE.

LightDM works well but when the user stays logged in form some time (say 2h), it becomes very slow, which you can see when trying to log out or to shut the machine down.

It doesn't seem to matter how long you stay connected past some time, i.e. there is no noticeable difference of slowness after 2h and 4h. It also doesn't seem to affect the performance of the desktop environment, or at least not in a blatant way.

Furthermore, nothing crashes, it's just that LightDM takes an abnormally long time to shut down. Thus, I don't know what to report to help solve this issue.

I have not checked on versions other than 12.1-BETA3, but I don't remember having observed this behavior before.

For me, this issue is not critical since I can use startx instead of LightDM.
Comment 1 Vincent DEFERT 2019-10-09 14:34:24 UTC
Sorry, but further testing shows the problem doesn't affect LightDM but the X server.

What happens is the startup time of the X server is abnormally long when using the vesa and scfb drivers.

When logging out, LightDM's cleanup takes a reasonable time, but the screen remains black for quite a long time while LightDM starts its X server anew.
Comment 2 Vincent DEFERT 2019-10-09 19:21:15 UTC
Finally, the origin of the problem was he ig4 module causing at-spi-bus-launcher to hang.

I don't need ig4, I had just loaded it in an unsuccessful attempt to get the I2C touchpad of my Lenovo Ideapad 120S to work. I have removed it and everything works as before.
Comment 3 Ben Woods freebsd_committer 2019-10-10 10:04:53 UTC
Glad you found the issue - I was a bit perplexed when I first read this about what the issue could be.