Bug 241307 - [patch] x11/nvidia-driver: Update 430.50
Summary: [patch] x11/nvidia-driver: Update 430.50
Status: Closed DUPLICATE of bug 232645
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-17 06:08 UTC by Gleb Smirnoff
Modified: 2019-11-03 13:24 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments
update (5.66 KB, patch)
2019-10-17 06:08 UTC, Gleb Smirnoff
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gleb Smirnoff freebsd_committer 2019-10-17 06:08:50 UTC
Created attachment 208376 [details]
update

Update to new version required for luxury guys with new RTX cards. Patch attached.
Comment 1 Alex S 2019-10-17 11:55:16 UTC
To be fair, low(er) end Turing cards without RTX are available since February. Also see bug 232645.
Comment 2 H 2019-10-27 20:19:05 UTC
have a rtx 2060, cant use unless download and install manually 430.X drivers from nvidia, but they only work for X, not really opengl programs, when trying glxinfo, glxgears or installing games with Homura script allways have same error:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

so please someone update the driver to 430.X
Comment 3 Gleb Smirnoff freebsd_committer 2019-10-28 14:49:02 UTC
(In reply to H from comment #2)
With 430.50 installed via port with my patch I have glxinfo/glxgears running.
Comment 4 commit-hook freebsd_committer 2019-10-31 08:51:46 UTC
A commit references this bug:

Author: danfe
Date: Thu Oct 31 08:51:08 UTC 2019
New revision: 516138
URL: https://svnweb.freebsd.org/changeset/ports/516138

Log:
  Update NVidia driver to the latest long lived branch version 430.50.

  PR:	232645, 241307

Changes:
  head/x11/nvidia-driver/Makefile
  head/x11/nvidia-driver/distinfo
  head/x11/nvidia-driver/pkg-plist
Comment 5 Alexey Dokuchaev freebsd_committer 2019-11-03 13:24:39 UTC
Port was updated as of ports r516138.  Let's move any further discussion to bug #232645.

*** This bug has been marked as a duplicate of bug 232645 ***