Bug 241787 - graphics/drm causes machine reboot after upgrade from 12.0 to 12.1.
Summary: graphics/drm causes machine reboot after upgrade from 12.0 to 12.1.
Status: Closed DUPLICATE of bug 241101
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.1-RELEASE
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords: panic, regression
Depends on:
Blocks:
 
Reported: 2019-11-07 19:43 UTC by Tomasz "CeDeROM" CEDRO
Modified: 2019-11-08 21:06 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz "CeDeROM" CEDRO 2019-11-07 19:43:01 UTC
Hello world :-)

I have just upgraded my machine from 12.0-RELEASE to 12.1-RELEASE with `freebsd-update upgrade -r 12.1-RELEASE`. Unfortunately the DRM module causes machine to reboot on load. I had to get into single mode and remove DRM and i915 modules from rc.conf. I cannot see a DRM for 12.1 yet. Rebuilding module does not help. I am without DRM right now unable to use external monitor/projector.

Any hints welcome :-)
Tomek

FreeBSD 0xCFMX4 12.1-RELEASE FreeBSD 12.1-RELEASE r354233 GENERIC  amd64

0xCFMX4% pkg info drm-kmod
drm-kmod-g20190710
Name           : drm-kmod
Version        : g20190710
Installed on   : Thu Nov  7 11:55:49 2019 CET
Origin         : graphics/drm-kmod
Architecture   : FreeBSD:12:*
Prefix         : /usr/local
Categories     : graphics
Licenses       :
Maintainer     : x11@FreeBSD.org
WWW            : https://github.com/FreeBSDDesktop/kms-drm
Comment        : Metaport of DRM modules for the linuxkpi-based KMS components
Annotations    :
Flat size      : 0.00B
Description    :
amdgpu, i915, and radeon DRM modules for the linuxkpi-based KMS components on
amd64, i915 and radeonkms DRM modules from the former base DRM component on
other architectures.
Metaport for different versions of Linux DRM based on the FreeBSD version
in use. This port encompasses the recommendations of the FreeBSDDesktop team
of DRM versions for FreeBSD versions based on the last update to the LinuxKPI
in that code base. In general, the most recent supported stable DRM for a give
FreeBSD version will be installed. CURRENT receives the most recent development
DRM.
This port does not however hinder the expert user to make other decisions and
continue to install DRM ports directly.

WWW: https://github.com/FreeBSDDesktop/kms-drm
Comment 1 Mateusz Piotrowski freebsd_committer 2019-11-07 21:04:20 UTC
Could that be related?

https://github.com/FreeBSDDesktop/kms-drm/issues/183
Comment 2 Niclas Zeising freebsd_committer 2019-11-08 21:06:54 UTC

*** This bug has been marked as a duplicate of bug 241101 ***