Bug 241949 - net/dpdk: update 18.05.1 -> 18.11.5
Summary: net/dpdk: update 18.05.1 -> 18.11.5
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2019-11-13 15:44 UTC by Bruce Richardson
Modified: 2019-11-22 10:28 UTC (History)
1 user (show)

See Also:


Attachments
Diff file for update. (12.43 KB, patch)
2019-11-13 15:44 UTC, Bruce Richardson
no flags Details | Diff
V2 Patch of diff for update (15.96 KB, patch)
2019-11-14 17:42 UTC, Bruce Richardson
no flags Details | Diff
patch to update port to 18.11.5 (15.96 KB, patch)
2019-11-18 11:58 UTC, Bruce Richardson
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bruce Richardson 2019-11-13 15:44:29 UTC
Created attachment 209133 [details]
Diff file for update.

Update to currently supported LTS version to get updates and bug fixes.
Comment 1 Automation User 2019-11-13 15:54:01 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/95691570
Comment 2 Kurt Jaeger freebsd_committer 2019-11-13 20:54:01 UTC
On current-amd64:
/wrkdirs/usr/ports/net/dpdk/work/dpdk-stable-18.11.4/x86_64-native-bsdapp-clang/include/rte_dev.h:55:34: error: format string is not a string literal [-Werror,-Wformat-nonliteral]
                char buffer[vsnprintf(NULL, 0, fmt, ap) + 1];
Comment 3 Bruce Richardson 2019-11-14 17:42:20 UTC
Created attachment 209150 [details]
V2 Patch of diff for update

Reproduced warning on current. V2 patch now attached.
Comment 4 Bruce Richardson 2019-11-18 11:58:43 UTC
Created attachment 209227 [details]
patch to update port to 18.11.5

18.11.4 release had a regression, so 18.11.5 was released to fix that. Updating patch for port to take account of this.
Comment 5 Bruce Richardson 2019-11-22 10:28:53 UTC
The next long-term supported version of DPDK, version 19.11, is due to be released next week, so I'm closing this update request and will open a new one for a 19.11 update in due course.