Bug 242029 - devel/zathura-pdf-mupdf: undefined symbol to jbig2_ctx_new
Summary: devel/zathura-pdf-mupdf: undefined symbol to jbig2_ctx_new
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-17 13:37 UTC by mmatalka
Modified: 2020-08-05 13:51 UTC (History)
3 users (show)

See Also:
w.schwarzenfeld: maintainer-feedback? (uzsolt)


Attachments
Portrevision bump (372 bytes, patch)
2020-03-29 13:27 UTC, Zsolt Udvari
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mmatalka 2019-11-17 13:37:28 UTC
Latest port build of zathura-mupdf fails to load PDFs with the following error:

error: Could not load plugin '/usr/local/lib/zathura/libpdf-mupdf.so' (/usr/local/lib/libmupdf.so.1.16.0: Undefined symbol "jbig2_ctx_new").
Comment 1 Zsolt Udvari 2019-11-17 16:47:53 UTC
I can't reproduce it.
Did you maybe remove jbig2dec?

$ grep jbig2_ctx_new /usr/local/lib/libjbig2dec.so
Binary file /usr/local/lib/libjbig2dec.so matches
$ ldd /usr/local/lib/zathura/libpdf-mupdf.so | grep libjbig
        libjbig2dec.so.0 => /usr/local/lib/libjbig2dec.so.0 (0x808f42000)
$ pkg which /usr/local/lib/libjbig2dec.so.0
/usr/local/lib/libjbig2dec.so.0 was installed by package jbig2dec-0.16
Comment 2 mmatalka 2019-11-17 19:42:05 UTC
No jbig2dec is installed.  However it is perhaps because it's version 0.17?  I'm on FreeBSD-CURRENT.
Comment 3 Zsolt Udvari 2019-11-17 19:51:28 UTC
The graphics/zathura-pdf-mupdf depends on graphics/jbig2dec:
https://svnweb.freebsd.org/ports/head/graphics/zathura-pdf-mupdf/Makefile?revision=516270&view=markup#l19

So graphics/jbig2dec should installed. Maybe did you deinstall it with "pkg delete -f"?
Please try install it!
Comment 4 mmatalka 2019-11-17 19:59:28 UTC
jbig2dec is definitely installed,

> pkg info jbig2dec
jbig2dec-0.17
Name           : jbig2dec
Version        : 0.17
Installed on   : Mon Nov 11 09:27:05 2019 CET

> ls -l /usr/local/lib/libjbig2dec.so.0.0.0
-rwxr-xr-x  1 root  wheel  126048 Nov  9 02:42 /usr/local/lib/libjbig2dec.so.0.0.0
Comment 5 mmatalka 2019-11-17 20:00:21 UTC
> pkg which /usr/local/lib/libjbig2dec.so.0.0.0
/usr/local/lib/libjbig2dec.so.0.0.0 was installed by package jbig2dec-0.17
Comment 6 mmatalka 2019-11-17 20:00:53 UTC
Sorry, poor comma on my part.  I mean "No, jbig2dec is installed"
Comment 7 Zsolt Udvari 2019-11-18 04:32:07 UTC
(In reply to mmatalka from comment #6)
:)

Please run "grep jbig2_ctx_new /usr/local/lib/libjbig2dec.so". I think in the newest version this function disappeared (I'm using quarterly repo).
Comment 8 mmatalka 2019-11-18 09:24:44 UTC
> grep jbig2_ctx_new /usr/local/lib/libjbig2dec.so
Binary file /usr/local/lib/libjbig2dec.so matches

There is also a discussion about this in the debian mailing lists (although the jbig2dec version seems older than mine)

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=940605
Comment 9 mmatalka 2019-11-25 16:58:14 UTC
Hi, any updates on this?
Comment 10 Zsolt Udvari 2019-11-25 18:13:47 UTC
(In reply to mmatalka from comment #9)
Working on it but I didn't have too many time.
Comment 11 mmatalka 2019-11-26 10:24:24 UTC
Anything I can do to help?
Comment 12 Zsolt Udvari 2019-11-26 11:28:44 UTC
(In reply to mmatalka from comment #11)
If you've time and can create (and test) patch would be nice :)
Comment 13 mmatalka 2019-12-06 12:21:23 UTC
I'm not actually sure what the fix is, do you have a suggestion?  Which package needs a fix?
Comment 14 Zsolt Udvari 2019-12-08 14:57:54 UTC
I rebuild zathura-pdf-mupdf with latest jbig2dec and install on my machine (quarterly repo, jbig2dec 0.16, not 0.17) and works well.
I think it will be the solution in jbig2dec 0.17. Added its maintainer.
Comment 15 Walter Schwarzenfeld freebsd_triage 2019-12-25 00:11:05 UTC
Does the problem after update of jbig2dec to 0.17 ( ports r516657 ) still extists?
Comment 16 Walter Schwarzenfeld freebsd_triage 2019-12-25 00:12:06 UTC
Sorry , overlooked some thing, is already answered.
Comment 17 Ivan 2020-03-29 11:48:41 UTC
Any news? It's becoming harder to downgrade jbig2dec as more and more ports use the new version.
Comment 18 Zsolt Udvari 2020-03-29 12:33:05 UTC
I don't have time to figure it. If you've any idea... :)
Comment 19 Ivan 2020-03-29 13:07:29 UTC
Looks like this one https://www.freshports.org/graphics/mupdf/ needs revision bump after jbig2 upgrade.

I have no issues after I rebuilt and force reinstalled mupdf.

BTW, upstream has newer version of the library.
Comment 20 mmatalka 2020-03-29 13:22:20 UTC
Ivan, do you have a patch?  Or just did it quickly in your own ports tree?
Comment 21 Zsolt Udvari 2020-03-29 13:27:36 UTC
Created attachment 212829 [details]
Portrevision bump

The simplest solution :)
Comment 22 Zsolt Udvari 2020-03-29 13:27:56 UTC
(In reply to mmatalka from comment #20)
Thanks! I didn't think it's so easy :(
Comment 23 mmatalka 2020-03-29 14:41:40 UTC
I don't know how ports work very well, is this literally just forcing it to rebuild?
Comment 24 Zsolt Udvari 2020-03-29 18:38:25 UTC
(In reply to mmatalka from comment #23)
Yes. See: https://www.freebsd.org/doc/en/books/porters-handbook/book.html#makefile-naming-revepoch
Comment 25 Zsolt Udvari 2020-07-23 12:14:54 UTC
Is this bug exists now?
Comment 26 mmatalka 2020-08-05 08:52:44 UTC
I believe this bug is resolved.
Comment 27 Zsolt Udvari 2020-08-05 08:58:20 UTC
I'm glad :)
Could you please close it?