Bug 242116 - lang/php73: fix build on powerpc64 elfv2
Summary: lang/php73: fix build on powerpc64 elfv2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Torsten Zuehlsdorff
URL:
Keywords:
: 242115 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-11-20 18:27 UTC by Piotr Kubaj
Modified: 2019-11-27 20:08 UTC (History)
0 users

See Also:
tz: maintainer-feedback+


Attachments
patch (468 bytes, patch)
2019-11-20 18:27 UTC, Piotr Kubaj
tz: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2019-11-20 18:27:36 UTC
Created attachment 209285 [details]
patch

DTRACE for now doesn't work on ELFv2, disable DTRACE on powerpc64 for now.
Comment 1 Walter Schwarzenfeld freebsd_triage 2019-11-20 20:24:41 UTC
*** Bug 242115 has been marked as a duplicate of this bug. ***
Comment 2 Torsten Zuehlsdorff freebsd_committer 2019-11-27 14:10:59 UTC
Comment on attachment 209285 [details]
patch

Looks fine to me, please go ahead! :)
Comment 3 commit-hook freebsd_committer 2019-11-27 19:58:42 UTC
A commit references this bug:

Author: pkubaj
Date: Wed Nov 27 19:58:32 UTC 2019
New revision: 518531
URL: https://svnweb.freebsd.org/changeset/ports/518531

Log:
  lang/php7*: disable DTRACE on powerpc64

  php ports don't build on elfv2 with DTRACE.

  PR:		242113, 242114, 242116
  Approved by:	tz (maintainer), tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D22577
  Differential Revision:	https://reviews.freebsd.org/D22578
  Differential Revision:	https://reviews.freebsd.org/D22579

Changes:
  head/lang/php71/Makefile
  head/lang/php72/Makefile
  head/lang/php73/Makefile