Bug 242288 - devel/py-backports.csv: Remove incorrect Python version-spec (2.7) restriction
Summary: devel/py-backports.csv: Remove incorrect Python version-spec (2.7) restriction
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-python mailing list
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2019-11-28 22:39 UTC by Greg V
Modified: 2019-12-08 17:48 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2019-11-28 22:39:10 UTC
Currently, the backports packages are built only on 2.7, and e.g. py-internetarchive only depends on backports.csv on 2.7.

This is wrong:

Traceback (most recent call last):
  File "/usr/local/bin/ia", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3241, in <module>
    @_call_aside
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3225, in _call_aside
    f(*args, **kwargs)
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3254, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/local/lib/python3.6/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'backports.csv' distribution was not found and is required by internetarchive


These backports packages actually have checks for PY3 inside them, they are not conditional dependencies.
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2019-11-29 01:55:54 UTC
Thank you for the report Greg

Per backports.csv trove classifiers:

Python :: 2
Python :: 2.6
Python :: 2.7
Python :: 3
Python :: 3.3
Python :: 3.4
Python :: 3.5
Python :: 3.6
Python :: 3.7 

These backports are not *just* for 2.7

@Greg Could you provide:

(1) A list of backports that have their python <version-specs> incorrectly limited to 2.7
(2) Confirm that for each of (1), that they are appropriate for, and support Python 3.x
(3) If any of the results of (2) show that they are not appropriate for specific 3.x versions (such as an upper version limit), please note those explicitly too

Thanks!

^Triage: As this involves multiple python ports, and python ports and framework compliance with regard to correct version specifications, assign this to python@ keeping original maintainer (of backports.csv) CC'd
Comment 2 commit-hook freebsd_committer 2019-12-08 17:33:00 UTC
A commit references this bug:

Author: sunpoet
Date: Sun Dec  8 17:32:31 UTC 2019
New revision: 519566
URL: https://svnweb.freebsd.org/changeset/ports/519566

Log:
  Relax USES=python

  PR:		242288
  Reported by:	Greg V <greg@unrelenting.technology>

Changes:
  head/devel/py-backports.csv/Makefile
Comment 3 Sunpoet Po-Chuan Hsieh freebsd_committer 2019-12-08 17:48:35 UTC
Committed. Thanks!