Bug 242327 - java/intellij: Fix packing list
Summary: java/intellij: Fix packing list
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Boris Samorodov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-11-30 20:29 UTC by Greg Lewis
Modified: 2019-12-02 06:16 UTC (History)
0 users

See Also:
bsam: maintainer-feedback+


Attachments
Patch to fix the packing list (3.32 KB, patch)
2019-11-30 20:29 UTC, Greg Lewis
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Lewis freebsd_committer 2019-11-30 20:29:17 UTC
Created attachment 209562 [details]
Patch to fix the packing list

Some of the JARs listed in the packing list use %%PYTHON_VER%% for part of their version number.  The problem is that these versions are the version numbers of the  release of that JAR, and are unrelated with Python.  E.g. most are due to the version of Maven bundled with IntelliJ IDEA, which has no relationship to the version of Python that might be in use on the system.

This breaks the package for anyone who isn't using python 3.6.  The attached patch removes the incorrect use of %%PYTHON_VER%%.
Comment 1 Boris Samorodov freebsd_committer 2019-11-30 20:31:48 UTC
Oh, that's not the first time... Sorry. Approved.
Comment 2 Boris Samorodov freebsd_committer 2019-12-01 16:32:30 UTC
Oh, that's not the first time... Sorry. Approved.
Comment 3 commit-hook freebsd_committer 2019-12-02 06:13:34 UTC
A commit references this bug:

Author: glewis
Date: Mon Dec  2 06:13:20 UTC 2019
New revision: 518825
URL: https://svnweb.freebsd.org/changeset/ports/518825

Log:
  Fix packing list

  The versions of the Apache Commons Net and Maven JARs are not related to
  the Python version.

  PR:		242327
  Approved by:	bsam@ (maintainer)

Changes:
  head/java/intellij/pkg-plist