Bug 242399 - textproc/elasticsearch6 not compiling/install on FreeBSD 11.3-RELEASE-p5
Summary: textproc/elasticsearch6 not compiling/install on FreeBSD 11.3-RELEASE-p5
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-elastic (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-03 10:19 UTC by Emanuele
Modified: 2019-12-03 10:47 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (elastic)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emanuele 2019-12-03 10:19:29 UTC
On a fresh new FreeBSD jail, elasticsearch6 port does not compile & install correctly.

Step to reproduce the issue:
1. create a new iocage jail with FreeBSD 11.3-RELEASE-p5
2. > portsnap fetch extract update
3. > cd /usr/ports/textproc/elasticsearch6 && make install clean
4. Click OK at every prompt

---
root@freebsd:/usr/ports/textproc/elasticsearch6 # make install clean
===>   elasticsearch6-6.8.5 depends on package: jna>0 - not found
===>   jna-4.5.2 depends on file: /usr/local/openjdk8/bin/java - not found
===>   openjdk8-8.232.09.1_1 depends on executable: zip - found
===>   openjdk8-8.232.09.1_1 depends on package: autoconf>0 - found
===>   openjdk8-8.232.09.1_1 depends on file: /usr/local/include/cups/cups.h - not found
===>   cups-2.2.12 depends on executable: gmake - found
===>   cups-2.2.12 depends on package: libiconv>=1.14_11 - found
===>   cups-2.2.12 depends on package: pkgconf>=1.3.0_1 - found
===>   cups-2.2.12 depends on shared library: libavahi-client.so - not found
===>   avahi-app-0.7_2 depends on executable: msgfmt - found
===>   avahi-app-0.7_2 depends on executable: gmake - found
===>   avahi-app-0.7_2 depends on file: /usr/local/bin/intltool-extract - found
===>   avahi-app-0.7_2 depends on package: pkgconf>=1.3.0_1 - found
===>   avahi-app-0.7_2 depends on shared library: libexpat.so - found (/usr/local/lib/libexpat.so)
===>   avahi-app-0.7_2 depends on shared library: libdaemon.so - found (/usr/local/lib/libdaemon.so)
===>   avahi-app-0.7_2 depends on shared library: libdbus-glib-1.so - found (/usr/local/lib/libdbus-glib-1.so)
===>   avahi-app-0.7_2 depends on shared library: libdbus-1.so - found (/usr/local/lib/libdbus-1.so)
===>   avahi-app-0.7_2 depends on shared library: libgdbm.so - found (/usr/local/lib/libgdbm.so)
===>   avahi-app-0.7_2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   avahi-app-0.7_2 depends on shared library: libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>   avahi-app-0.7_2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   avahi-app-0.7_2 depends on shared library: libgirepository-1.0.so - not found
===>   gobject-introspection-1.56.1,1 depends on executable: cairo-trace - not found
===>   cairo-1.16.0,2 depends on package: pkgconf>=1.3.0_1 - found
===>   cairo-1.16.0,2 depends on package: xorgproto>=0 - found
===>   cairo-1.16.0,2 depends on package: xorgproto>=0 - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/pixman-1.pc - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/x11.pc - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/xext.pc - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/xrender.pc - found
===>   cairo-1.16.0,2 depends on file: /usr/local/libdata/pkgconfig/xcb.pc - found
===>   cairo-1.16.0,2 depends on shared library: libfreetype.so - found (/usr/local/lib/libfreetype.so)
===>   cairo-1.16.0,2 depends on shared library: libpng.so - found (/usr/local/lib/libpng.so)
===>   cairo-1.16.0,2 depends on shared library: libfontconfig.so - found (/usr/local/lib/libfontconfig.so)
===>   cairo-1.16.0,2 depends on shared library: libglib-2.0.so - found (/usr/local/lib/libglib-2.0.so)
===>   cairo-1.16.0,2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   cairo-1.16.0,2 depends on shared library: libintl.so - found (/usr/local/lib/libintl.so)
===>   cairo-1.16.0,2 depends on shared library: libGL.so - not found
===>   mesa-libs-18.3.2_3 depends on package: wayland-protocols>=1.8 - found
===>   mesa-libs-18.3.2_3 depends on file: /usr/local/libdata/pkgconfig/pthread-stubs.pc - found
===>   mesa-libs-18.3.2_3 depends on executable: bison - found
===>   mesa-libs-18.3.2_3 depends on executable: msgfmt - found
===>   mesa-libs-18.3.2_3 depends on executable: gmake - found
===>   mesa-libs-18.3.2_3 depends on package: pkgconf>=1.3.0_1 - found
===>   mesa-libs-18.3.2_3 depends on file: /usr/local/bin/python2.7 - found
===>   mesa-libs-18.3.2_3 depends on package: llvm80>=3.9.0_4 - not found
===>  llvm80-8.0.1_3 needs Python 3.6 at least, but 2.7 was specified.
*** Error code 1

Stop.
make[14]: stopped in /usr/ports/devel/llvm80
*** Error code 1

Stop.
make[13]: stopped in /usr/ports/graphics/mesa-libs
*** Error code 1

Stop.
make[12]: stopped in /usr/ports/graphics/mesa-libs
*** Error code 1

Stop.
make[11]: stopped in /usr/ports/graphics/cairo
*** Error code 1

Stop.
make[10]: stopped in /usr/ports/graphics/cairo
*** Error code 1

Stop.
make[9]: stopped in /usr/ports/devel/gobject-introspection
*** Error code 1

Stop.
make[8]: stopped in /usr/ports/net/avahi-app
*** Error code 1

Stop.
make[7]: stopped in /usr/ports/print/cups
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/print/cups
*** Error code 1

Stop.
make[5]: stopped in /usr/ports/java/openjdk8
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/java/openjdk8
*** Error code 1

Stop.
make[3]: stopped in /usr/ports/devel/jna
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/devel/jna
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/textproc/elasticsearch6
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/elasticsearch6
Comment 1 Juraj Lutter 2019-12-03 10:32:13 UTC
This seems more like a improper make.conf settings:

===>   mesa-libs-18.3.2_3 depends on package: llvm80>=3.9.0_4 - not found
===>  llvm80-8.0.1_3 needs Python 3.6 at least, but 2.7 was specified.
*** Error code 1
Comment 2 Emanuele 2019-12-03 10:34:02 UTC
/etc/make.conf file is empty/non-existent. Should I create one?
Comment 3 Juraj Lutter 2019-12-03 10:47:10 UTC
Upgrade from python 2.7 to python 3.6 and specify the default version for python in /etc/make.conf.

Example:

DEFAULT_VERSIONS+=python=3.6
DEFAULT_VERSIONS+=python3=3.6