Bug 242613 - devel/cdialog: cdialog-1.3-20180621 displays ugly black bars
Summary: devel/cdialog: cdialog-1.3-20180621 displays ugly black bars
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-12 21:36 UTC by Serge Volkov
Modified: 2020-08-12 17:05 UTC (History)
5 users (show)

See Also:
jcpierri: maintainer-feedback+


Attachments
cdialog-1.3.20191210,2.patch (1.43 KB, patch)
2019-12-13 06:05 UTC, takefu
no flags Details | Diff
cdialog-1.3.20200228,2.patch (2.29 KB, patch)
2020-03-11 00:32 UTC, takefu
takefu: maintainer-approval+
Details | Diff
cdialog-1.3.20200327,2.patch (2.29 KB, patch)
2020-08-10 18:29 UTC, takefu
takefu: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Serge Volkov 2019-12-12 21:36:47 UTC
Prior to 1.3-20180621 cdialog would fill unused space at the end of the
line with the background color.  However, starting with 1.3-20180621
it doesn't. Instead, it seems to fill with whatever the terminal's
background color was prior to starting dialog.

Steps to reproduce on FreeBSD current:
cat /etc/rc.conf | cdialog --programbox 23 76

With older versions of dialog the box's background is a consistent
color.  With 1.3-20180621, the trailing unused part of each
line is filled with (on my terminal at least) black.

Details here https://lists.gnu.org/archive/html/bug-ncurses/2019-02/msg00010.html

The problem is evident in FreeBSD's ports tree's version.

The latest upstream version of dialog 1.3.20191210 fixes this problem for me.

Can someone update the version of devel/cdialog port?
Comment 1 takefu 2019-12-13 06:05:41 UTC
Created attachment 209907 [details]
cdialog-1.3.20191210,2.patch

Update to 1.3.20191210

fix
  STRIP_CMD
  patch-EXAMPLES
Comment 2 Serge Volkov 2019-12-18 14:31:03 UTC
With such changes when building and installing the port, I get the following:

Registering installation for cdialog-1.3.20191210,2
(cdialog-1.3.20191210,2) /usr/ports/devel/cdialog/work/stage//usr/local/bin/cdialog - required shared library libncursesw.so.8 not found
(cdialog-1.3.20191210,2) /usr/ports/devel/cdialog/work/stage//usr/local/bin/cdialog - required shared library libc.so.7 not found
Installing cdialog-1.3.20191210,2...

However, after this, a new cdialog works.
Comment 3 Serge Volkov 2019-12-19 09:09:31 UTC
Sorry. I tried again to patch, make and install. And everything turned out without errors.
Comment 4 Josmar 2019-12-22 21:02:13 UTC
Tested the patch and it works correctly on 12.1-RELEASE-p1 and 11.3-RELEASE-p5.
The issue reported no longer happens on either.
Good job!
Comment 5 Serge Volkov 2020-03-10 17:56:26 UTC
Can anyone update this port in the ports tree?
Comment 6 takefu 2020-03-11 00:32:29 UTC
Created attachment 212317 [details]
cdialog-1.3.20200228,2.patch

Update to 1.3-20200228
Comment 7 Tobias C. Berner freebsd_committer 2020-03-14 15:12:38 UTC
Moin moin 

Fails to pass qa:
===========================================================================
=>> Checking for filesystem violations... done
=>> Error: Filesystem touched during build:
var/run/ld-elf.so.hints:
        size (173, 129)
=>> Cleaning up wrkdir
===>  Cleaning for cdialog-1.3.20200228,2
build of devel/cdialog | cdialog-1.3.20200228,2 ended at Sat Mar 14 16:11:29 CET 2020


mfg Tobias
Comment 8 Serge Volkov 2020-03-14 16:10:36 UTC
(In reply to Tobias C. Berner from comment #7)

I tried patch 212317. Then I compiled and installed the port. And everything turned out without errors. It works for me.
Comment 9 Josmar 2020-03-16 01:30:07 UTC
(In reply to Tobias C. Berner from comment #7)

I checked it with portlint and got no complaints.
The build with make in developer mode also ended without complaints.
Portmaster builded it happily.
It seems that poudriere is the only one unhappy with it (I don't use poudriere, BTW)
Comment 10 Alan Somers freebsd_committer 2020-08-08 16:06:36 UTC
I don't see any problems in Poudriere when building for 11.4 or 12.1.  I can't reproduce the failure that tcberner saw.  And the patch produces the desired effect on FreeBSD 13.  Can we commit it?
Comment 11 takefu 2020-08-10 18:29:34 UTC
Created attachment 217133 [details]
cdialog-1.3.20200327,2.patch

Update to 1.3-20200327
Comment 12 commit-hook freebsd_committer 2020-08-12 16:59:50 UTC
A commit references this bug:

Author: asomers
Date: Wed Aug 12 16:59:27 UTC 2020
New revision: 544757
URL: https://svnweb.freebsd.org/changeset/ports/544757

Log:
  devel/cdialog: Update to 1.3-20200327

  This fixes ugly black bars that show up with cdialog 1.3-20180621

  PR:		242613
  Submitted by:	takefu@airport.fm
  Reported by:	Serge Volkov <sv@ulstu.ru>
  Approved by:	tcberner (ports)
  Approved by:	Josmar <jcpierri@gmail.com> (maintainer)

Changes:
  head/devel/cdialog/Makefile
  head/devel/cdialog/distinfo
  head/devel/cdialog/pkg-plist