Bug 242760 - net-p2p/deluge-cli fails to start since net-p2p/libtorrent-rasterbar update to 1.2.2
Summary: net-p2p/deluge-cli fails to start since net-p2p/libtorrent-rasterbar update t...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Ruslan Makhmatkhanov
URL:
Keywords: regression
: 244854 (view as bug list)
Depends on: 242797
Blocks:
  Show dependency treegraph
 
Reported: 2019-12-21 09:23 UTC by Wade
Modified: 2020-04-27 00:59 UTC (History)
11 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wade 2019-12-21 09:23:17 UTC
"service deluged start" fails with the following traceback after net-p2p/libtorrent-rasterbar was updated to 1.2.2 ports r520456


[ERROR   ] 19:07:18 main:248 No module named libtorrent
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/site-packages/deluge/main.py", line 241, in start_daemon
    Daemon(options, args)
  File "/usr/local/lib/python2.7/site-packages/deluge/core/daemon.py", line 144, in __init__
    from deluge.core.core import Core
  File "/usr/local/lib/python2.7/site-packages/deluge/core/core.py", line 38, in <module>
    from deluge._libtorrent import lt
  File "/usr/local/lib/python2.7/site-packages/deluge/_libtorrent.py", line 59, in <module>
    import libtorrent as lt
ImportError: No module named libtorrent
Comment 1 daniel.engberg.lists 2019-12-21 23:55:40 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=241202

It should be marked as BROKEN until update is in tree
Comment 2 Yuri Victorovich freebsd_committer 2019-12-21 23:57:38 UTC
The maintainer promised to update Deluge ports over the weekend.
Comment 3 Wade 2019-12-22 03:52:56 UTC
The proposed fix in bug #241202 is to bump deluge to the 2.x branch, which is completely incompatible with 1.x clients used for remote management. Deluge 2.x client support for is currently severely lacking, at least compared to 1.x.

Can deluge 1.x be patched to work with libtorrent-rasterbar 1.2.x?
Is libtorrent-rasterbar 1.2.x inherently incompatible with deluge 1.x?
Is there a way to force install libtorrent-rasterbar 1.1.10 (last known working)?
Comment 4 Yuri Victorovich freebsd_committer 2019-12-22 04:13:49 UTC
Assign to the port maintainer.
Comment 5 Ruslan Makhmatkhanov freebsd_committer 2019-12-22 09:22:32 UTC
If I understand correctly, py-libtorrent-rasterbar is broken - it doesn't installs anything. Look like some plist problem. This is why deluge is not capable to find libtorrent module.

[rm@cf ~]> pkg list py37-libtorrent-rasterbar-1.2.2
/usr/local/lib/python3.7/site-packages/python_libtorrent-1.2.2-py3.7.egg-info/PKG-INFO
/usr/local/lib/python3.7/site-packages/python_libtorrent-1.2.2-py3.7.egg-info/SOURCES.txt
/usr/local/lib/python3.7/site-packages/python_libtorrent-1.2.2-py3.7.egg-info/dependency_links.txt
/usr/local/lib/python3.7/site-packages/python_libtorrent-1.2.2-py3.7.egg-info/top_level.txt
/usr/local/share/licenses/py37-libtorrent-rasterbar-1.2.2/BSD3CLAUSE
/usr/local/share/licenses/py37-libtorrent-rasterbar-1.2.2/LICENSE
/usr/local/share/licenses/py37-libtorrent-rasterbar-1.2.2/catalog.mk

It only installs a bunch of text files.
Comment 6 Rene Ladan freebsd_committer 2020-03-01 17:43:53 UTC
Note that this port expired today due to still using Python 2.7 which got unsupported this year by upstream.
Comment 7 Yuri Victorovich freebsd_committer 2020-03-08 16:30:39 UTC
Somebody who uses Deluge should re-test it now because net-p2p/py-libtorrent-rasterbar has been updated to 1.2.4
Comment 8 jordy 2020-03-08 23:32:13 UTC
Just updated my ports tree to test the last fix. Still can't start deluged:

[ERROR   ] 00:30:48 main:248 'module' object has no attribute 'session_settings'
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/site-packages/deluge/main.py", line 241, in start_daemon
    Daemon(options, args)
  File "/usr/local/lib/python2.7/site-packages/deluge/core/daemon.py", line 147, in __init__
    read_only_config_keys=read_only_config_keys)
  File "/usr/local/lib/python2.7/site-packages/deluge/core/core.py", line 106, in __init__
    self.settings = lt.session_settings()
AttributeError: 'module' object has no attribute 'session_settings'
Comment 9 Yuri Victorovich freebsd_committer 2020-03-08 23:48:01 UTC
(In reply to jordy from comment #8)

> Just updated my ports tree to test the last fix. Still can't start deluged:

You need to take this up with https://github.com/arvidn/libtorrent


Yuri
Comment 10 jordy 2020-03-08 23:49:30 UTC
Apparently deluge 1.x isn't compatible with libtorrent 1.2.x.
The only solution is to upgrade to 2.x
Comment 11 daniel.engberg.lists 2020-03-09 07:10:30 UTC
1.2-branch also doesn't support Python 3 so it's going to be axed anyway.
Comment 12 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-17 22:43:46 UTC
*** Bug 244854 has been marked as a duplicate of this bug. ***
Comment 13 Kubilay Kocak freebsd_committer freebsd_triage 2020-03-17 22:44:34 UTC
Is there an open upstream issue (or discussion, PR, commit) for this?
Comment 14 daniel.engberg.lists 2020-03-18 09:44:13 UTC
Deluge (and cli port) simply needs to be updated to 2.0-branch, there's no PR and upstream doesn't intend to backport this as 2.0 was released to fix compatibility with libtorrent 1.2-branch. Source: https://deluge.readthedocs.io/en/latest/releases/2.0.html

As I suggested here ( https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=242760#c1 ) these ports should be marked as broken until update is in tree.
Comment 15 Ruslan Makhmatkhanov freebsd_committer 2020-03-18 10:02:34 UTC
Hello, I'm now testing deluge 2.0.3 update and going to update it in the ports tree this week. Upstream switched to client/server model, so rc-scripts also should be adjusted accordingly to get it working. Please hold on.
Comment 16 Sam H 2020-04-03 19:47:35 UTC
Where is the promised update to Deluge 2?
Comment 17 Sam H 2020-04-09 19:05:43 UTC
(In reply to Ruslan Makhmatkhanov from comment #15)
Deluge port is still totally broken because of the libtorrent update. Even holding the package back, its other dependencies are being linked against new shared objects (ssl) and making it more broken. Please update the Deluge port.
Comment 18 Ruslan Makhmatkhanov freebsd_committer 2020-04-22 15:11:42 UTC
libtorrent-rasterbar-python package was fixed for sometime already and deluge was just updated to 2.0.3. Closing.
Comment 19 Dmitry Bachilo 2020-04-27 00:59:33 UTC
===>  Building for py37-libtorrent-rasterbar-1.2.6
running build
running build_ext
building 'libtorrent' extension
creating build
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr/ports
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr/ports/net-p2p
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr/ports/net-p2p/py-libtorrent-rasterbar
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python
creating build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src
cc -Wno-unused-result -Wsign-compare -Wunreachable-code -DNDEBUG -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -O2 -pipe -DTORRENT_DISABLE_LOGGING -DLIBICONV_PLUG -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing -DLIBICONV_PLUG -isystem /usr/local/include -fPIC -I/usr/local/include/python3.7m -c /usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp -o build/temp.freebsd-12.1-RELEASE-p2-amd64-3.7/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.o
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:169:15: warning: 'resume_data' is deprecated [-Wdeprecated-declarations]
        return *self.resume_data;
                     ^
/usr/local/include/libtorrent/alert_types.hpp:1162:26: note: 'resume_data' has been explicitly marked deprecated here
                std::shared_ptr<entry> TORRENT_DEPRECATED_MEMBER resume_data;
                                       ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:44:53: note: expanded from macro 'TORRENT_DEPRECATED_MEMBER'
#  define TORRENT_DEPRECATED_MEMBER __attribute__ ((deprecated))
                                                    ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:314:38: warning: 'severity' is deprecated [-Wdeprecated-declarations]
            .def("severity", &alert::severity)
                                     ^
/usr/local/include/libtorrent/alert.hpp:286:3: note: 'severity' has been explicitly marked deprecated here
                TORRENT_DEPRECATED
                ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:42:46: note: expanded from macro 'TORRENT_DEPRECATED'
#  define TORRENT_DEPRECATED __attribute__ ((deprecated))
                                             ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:320:22: warning: 'severity_t' is deprecated [-Wdeprecated-declarations]
        enum_<alert::severity_t>("severity_levels")
                     ^
/usr/local/include/libtorrent/alert.hpp:96:8: note: 'severity_t' has been explicitly marked deprecated here
                enum TORRENT_DEPRECATED_ENUM severity_t { debug, info, warning, critical, fatal, none };
                     ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:43:51: note: expanded from macro 'TORRENT_DEPRECATED_ENUM'
#  define TORRENT_DEPRECATED_ENUM __attribute__ ((deprecated))
                                                  ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:321:36: warning: 'debug' is deprecated [-Wdeprecated-declarations]
            .value("debug", alert::debug)
                                   ^
/usr/local/include/libtorrent/alert.hpp:96:8: note: 'severity_t' has been explicitly marked deprecated here
                enum TORRENT_DEPRECATED_ENUM severity_t { debug, info, warning, critical, fatal, none };
                     ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:43:51: note: expanded from macro 'TORRENT_DEPRECATED_ENUM'
#  define TORRENT_DEPRECATED_ENUM __attribute__ ((deprecated))
                                                  ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:322:35: warning: 'info' is deprecated [-Wdeprecated-declarations]
            .value("info", alert::info)
                                  ^
/usr/local/include/libtorrent/alert.hpp:96:8: note: 'severity_t' has been explicitly marked deprecated here
                enum TORRENT_DEPRECATED_ENUM severity_t { debug, info, warning, critical, fatal, none };
                     ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:43:51: note: expanded from macro 'TORRENT_DEPRECATED_ENUM'
#  define TORRENT_DEPRECATED_ENUM __attribute__ ((deprecated))
                                                  ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:323:38: warning: 'warning' is deprecated [-Wdeprecated-declarations]
            .value("warning", alert::warning)
                                     ^
/usr/local/include/libtorrent/alert.hpp:96:8: note: 'severity_t' has been explicitly marked deprecated here
                enum TORRENT_DEPRECATED_ENUM severity_t { debug, info, warning, critical, fatal, none };
                     ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:43:51: note: expanded from macro 'TORRENT_DEPRECATED_ENUM'
#  define TORRENT_DEPRECATED_ENUM __attribute__ ((deprecated))
                                                  ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:324:39: warning: 'critical' is deprecated [-Wdeprecated-declarations]
            .value("critical", alert::critical)
                                      ^
/usr/local/include/libtorrent/alert.hpp:96:8: note: 'severity_t' has been explicitly marked deprecated here
                enum TORRENT_DEPRECATED_ENUM severity_t { debug, info, warning, critical, fatal, none };
                     ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:43:51: note: expanded from macro 'TORRENT_DEPRECATED_ENUM'
#  define TORRENT_DEPRECATED_ENUM __attribute__ ((deprecated))
                                                  ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:325:36: warning: 'fatal' is deprecated [-Wdeprecated-declarations]
            .value("fatal", alert::fatal)
                                   ^
/usr/local/include/libtorrent/alert.hpp:96:8: note: 'severity_t' has been explicitly marked deprecated here
                enum TORRENT_DEPRECATED_ENUM severity_t { debug, info, warning, critical, fatal, none };
                     ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:43:51: note: expanded from macro 'TORRENT_DEPRECATED_ENUM'
#  define TORRENT_DEPRECATED_ENUM __attribute__ ((deprecated))
                                                  ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:326:35: warning: 'none' is deprecated [-Wdeprecated-declarations]
            .value("none", alert::none)
                                  ^
/usr/local/include/libtorrent/alert.hpp:96:8: note: 'severity_t' has been explicitly marked deprecated here
                enum TORRENT_DEPRECATED_ENUM severity_t { debug, info, warning, critical, fatal, none };
                     ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:43:51: note: expanded from macro 'TORRENT_DEPRECATED_ENUM'
#  define TORRENT_DEPRECATED_ENUM __attribute__ ((deprecated))
                                                  ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:339:47: warning: 'debug_notification' is deprecated [-Wdeprecated-declarations]
        s.attr("debug_notification") = alert::debug_notification;
                                              ^
/usr/local/include/libtorrent/alert.hpp:131:37: note: 'debug_notification' has been explicitly marked deprecated here
                static constexpr alert_category_t TORRENT_DEPRECATED_MEMBER debug_notification = connect_notification;
                                                  ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:44:53: note: expanded from macro 'TORRENT_DEPRECATED_MEMBER'
#  define TORRENT_DEPRECATED_MEMBER __attribute__ ((deprecated))
                                                    ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:340:50: warning: 'progress_notification' is deprecated [-Wdeprecated-declarations]
        s.attr("progress_notification") = alert::progress_notification;
                                                 ^
/usr/local/include/libtorrent/alert.hpp:140:37: note: 'progress_notification' has been explicitly marked deprecated here
                static constexpr alert_category_t TORRENT_DEPRECATED_MEMBER progress_notification = 7_bit;
                                                  ^
/usr/local/include/libtorrent/aux_/deprecated.hpp:44:53: note: expanded from macro 'TORRENT_DEPRECATED_MEMBER'
#  define TORRENT_DEPRECATED_MEMBER __attribute__ ((deprecated))
                                                    ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:363:27: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("error") = alert_category::error;
                          ^~~~~~~~~~~~~~
                          alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:363:43: error: no member named 'error' in 'libtorrent::flags::bitfield_flag<unsigned int,
      libtorrent::alert_category_tag, void>'
        s.attr("error") = alert_category::error;
                          ~~~~~~~~~~~~~~~~^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:364:26: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("peer") = alert_category::peer;
                         ^~~~~~~~~~~~~~
                         alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:364:42: error: no member named 'peer' in 'libtorrent::flags::bitfield_flag<unsigned int,
      libtorrent::alert_category_tag, void>'
        s.attr("peer") = alert_category::peer;
                         ~~~~~~~~~~~~~~~~^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:365:34: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("port_mapping") = alert_category::port_mapping;
                                 ^~~~~~~~~~~~~~
                                 alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:365:50: error: no member named 'port_mapping' in 'libtorrent::flags::bitfield_flag<unsigned int,
      libtorrent::alert_category_tag, void>'
        s.attr("port_mapping") = alert_category::port_mapping;
                                 ~~~~~~~~~~~~~~~~^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:366:29: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("storage") = alert_category::storage;
                            ^~~~~~~~~~~~~~
                            alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:366:45: error: no member named 'storage' in 'libtorrent::flags::bitfield_flag<unsigned int,
      libtorrent::alert_category_tag, void>'
        s.attr("storage") = alert_category::storage;
                            ~~~~~~~~~~~~~~~~^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:367:29: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("tracker") = alert_category::tracker;
                            ^~~~~~~~~~~~~~
                            alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:367:45: error: no member named 'tracker' in 'libtorrent::flags::bitfield_flag<unsigned int,
      libtorrent::alert_category_tag, void>'
        s.attr("tracker") = alert_category::tracker;
                            ~~~~~~~~~~~~~~~~^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:368:29: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("connect") = alert_category::connect;
                            ^~~~~~~~~~~~~~
                            alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:368:29: error: no member named 'connect' in 'libtorrent::flags::bitfield_flag<unsigned int,
      libtorrent::alert_category_tag, void>'; did you mean simply 'connect'?
        s.attr("connect") = alert_category::connect;
                            ^~~~~~~~~~~~~~~~~~~~~~~
                            connect
/usr/include/sys/socket.h:662:5: note: 'connect' declared here
int     connect(int, const struct sockaddr *, socklen_t);
        ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:369:28: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("status") = alert_category::status;
                           ^~~~~~~~~~~~~~
                           alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:369:44: error: no member named 'status' in 'libtorrent::flags::bitfield_flag<unsigned int,
      libtorrent::alert_category_tag, void>'
        s.attr("status") = alert_category::status;
                           ~~~~~~~~~~~~~~~~^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:370:30: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("ip_block") = alert_category::ip_block;
                             ^~~~~~~~~~~~~~
                             alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:370:30: error: no member named 'ip_block' in 'libtorrent::flags::bitfield_flag<unsigned int,
      libtorrent::alert_category_tag, void>'; did you mean 'sigblock'?
        s.attr("ip_block") = alert_category::ip_block;
                             ^~~~~~~~~~~~~~~~~~~~~~~~
                             sigblock
/usr/include/signal.h:125:5: note: 'sigblock' declared here
int     sigblock(int);
        ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:371:41: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("performance_warning") = alert_category::performance_warning;
                                        ^~~~~~~~~~~~~~
                                        alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:371:41: error: no member named 'performance_warning' in 'libtorrent::flags::bitfield_flag<unsigned int,
      libtorrent::alert_category_tag, void>'; did you mean 'libtorrent::alert::performance_warning'?
        s.attr("performance_warning") = alert_category::performance_warning;
                                        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                                        libtorrent::alert::performance_warning
/usr/local/include/libtorrent/alert.hpp:148:37: note: 'libtorrent::alert::performance_warning' declared here
                static constexpr alert_category_t performance_warning = 9_bit;
                                                  ^
/usr/ports/net-p2p/py-libtorrent-rasterbar/work-py37/libtorrent-libtorrent-1_2_6/bindings/python/src/alert.cpp:372:25: error: use of undeclared identifier 'alert_category'; did you mean 'alert_category_t'?
        s.attr("dht") = alert_category::dht;
                        ^~~~~~~~~~~~~~
                        alert_category_t
/usr/local/include/libtorrent/alert.hpp:71:8: note: 'alert_category_t' declared here
        using alert_category_t = flags::bitfield_flag<std::uint32_t, struct alert_category_tag>;
              ^
fatal error: too many errors emitted, stopping now [-ferror-limit=]
11 warnings and 20 errors generated.
error: command 'cc' failed with exit status 1
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/net-p2p/py-libtorrent-rasterbar
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/net-p2p/deluge-cli
*** Error code 1

Stop.
make: stopped in /usr/ports/net-p2p/deluge-cli