Bug 242823 - deskutils/kdepim: kdepim regressions after the latest updates
Summary: deskutils/kdepim: kdepim regressions after the latest updates
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-kde (Team)
URL: https://bugs.archlinux.org/task/64888
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-23 02:08 UTC by Greg Rivers
Modified: 2019-12-27 04:30 UTC (History)
2 users (show)

See Also:
tcberner: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Rivers 2019-12-23 02:08:42 UTC
I updated the packages on my laptop yesterday from the "latest" pkg repo. The following installed packages were updated:

Dec 21 18:32:36 xxxxx pkg[10634]: libvpx upgraded: 1.8.1_1 -> 1.8.2 
Dec 21 18:32:36 xxxxx pkg[10634]: libvdpau upgraded: 1.1.1_2 -> 1.3 
Dec 21 18:32:36 xxxxx pkg[10634]: aom upgraded: 1.0.0.2847 -> 1.0.0.2859 
Dec 21 18:32:38 xxxxx pkg[10634]: ffmpeg upgraded: 4.2.1_18,1 -> 4.2.1_20,1 
Dec 21 18:32:38 xxxxx pkg[10634]: grantlee5 upgraded: 5.1.0_7 -> 5.2.0 
Dec 21 18:32:38 xxxxx pkg[10634]: akonadi-contacts upgraded: 19.12.0 -> 19.12.0_1 
Dec 21 18:32:39 xxxxx pkg[10634]: kpimtextedit upgraded: 19.12.0 -> 19.12.0_1 
Dec 21 18:32:39 xxxxx pkg[10634]: pimcommon upgraded: 19.12.0 -> 19.12.0_1 
Dec 21 18:32:39 xxxxx pkg[10634]: grantleetheme upgraded: 19.12.0 -> 19.12.0_1 
Dec 21 18:32:44 xxxxx pkg[10634]: thunderbird upgraded: 68.3.1 -> 68.3.1_1 
Dec 21 18:32:45 xxxxx pkg[10634]: rocs upgraded: 19.12.0 -> 19.12.0_1 
Dec 21 18:32:45 xxxxx pkg[10634]: libssh upgraded: 0.9.2 -> 0.9.3 
Dec 21 18:32:46 xxxxx pkg[10634]: khelpcenter upgraded: 19.12.0 -> 19.12.0_1 
Dec 21 18:32:50 xxxxx pkg[10634]: kf5-oxygen-icons5 upgraded: 5.64.0 -> 5.65.0 
Dec 21 18:32:51 xxxxx pkg[10634]: kdepim-apps-libs upgraded: 19.12.0 -> 19.12.0_1 
Dec 21 18:32:51 xxxxx pkg[10634]: kcalutils upgraded: 19.12.0 -> 19.12.0_1 
Dec 21 18:32:56 xxxxx pkg[10634]: firefox upgraded: 71.0_2,1 -> 71.0_4,1 

Afterwards, KAddressBook no longer displays contact information. There is an error message "Plugin library 'grantlee_scriptabletags' not found." where the contact would normally be displayed.

In addition, KMail no longer displays message bodies, only headers.
Comment 1 Greg Rivers 2019-12-23 08:06:05 UTC
Looking at ~/.local/share/sddm/xorg-session.log I see the following error logged whenever I open a new message in KMail:

org.kde.pim.akonadiserver: ItemRetrievalJob for request 0x8066a8bc0 finished
grantlee.template: "Plugin library 'grantlee_scriptabletags' not found."
org.kde.pim.messageviewer: "Plugin library 'grantlee_scriptabletags' not found." . Searched in subdir mimetreeparser/themes/default in these locations ("/home/gcr/.local/share", "/usr/local/share", "/usr/share")

So both the KAddressBook and the KMail problems seem to have been caused by the grantlee5 update.
Comment 2 Tobias C. Berner freebsd_committer 2019-12-24 05:18:30 UTC
Moin moin

Intersting... I was unable to reproduce this on my computer at home, however, I have the same issue at work.

I'll look into it.

mfg Tobias
Comment 3 commit-hook freebsd_committer 2019-12-24 05:34:19 UTC
A commit references this bug:

Author: tcberner
Date: Tue Dec 24 05:33:55 UTC 2019
New revision: 520776
URL: https://svnweb.freebsd.org/changeset/ports/520776

Log:
  devel/grantlee5: add dependency on declarative (regression fix)

  PR:		242823
  Obtained from:	arch

Changes:
  head/devel/grantlee5/Makefile
Comment 4 Greg Rivers 2019-12-26 22:12:59 UTC
Thank you Tobias, your update fixed the problem.