Bug 243015 - www/firefox: Fails to build outside of /usr/ports: system_wrappers/string.h:3:15: fatal error: 'String.h' file not found
Summary: www/firefox: Fails to build outside of /usr/ports: system_wrappers/string.h:3...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords: needs-qa
: 243016 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-01-01 00:37 UTC by Daniel Morante
Modified: 2020-02-01 04:34 UTC (History)
0 users

See Also:
jbeich: maintainer-feedback+
koobs: merge-quarterly?


Attachments
Snippet of console output (28.09 KB, text/plain)
2020-01-01 00:37 UTC, Daniel Morante
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Morante 2020-01-01 00:37:32 UTC
Created attachment 210364 [details]
Snippet of console output

When attempting to build this port on a ports tree that is not located under `/usr/ports/` it will fail with the following error:

```
/usr/home/daniel/Development/ports/www/firefox/work/.build/dist/system_wrappers/string.h:3:15: fatal error: 'String.h' file not found
```

To reproduce:

```
cd ~
mkdir Development
cd Development
svnlite checkout http://svn0.us-east.freebsd.org/ports/head ports
cd www/firefox
make build
````
Comment 1 Daniel Morante 2020-01-01 02:27:33 UTC
*** Bug 243016 has been marked as a duplicate of this bug. ***
Comment 2 Jan Beich freebsd_committer 2020-01-01 08:39:14 UTC
I can't reproduce. Can you proide build log from poudriere or something similar with lots of details about the environment captured?

{BUILD_WRKSRC}/dist/system_wrappers/string.h including String.h instead of string.h is weird. According to ${WRKSRC}/config/make-system-wrappers.py the header names should printed as is within the template, not with the first letter capitalized. One way it could happen if both string.h and String.h wrappers got written into the same file (e.g., on a case-insensitive filesystem) but according to C collation 'S' comes before 's'.
Comment 3 Daniel Morante 2020-02-01 04:34:25 UTC
This can be closed.  Turns out it was an issue with my build environment.