Bug 243446 - dns/getdns getdns-1.5.2 error: getdns does not support LibreSSL
Summary: dns/getdns getdns-1.5.2 error: getdns does not support LibreSSL
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Ryan Steinmetz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-01-19 12:44 UTC by p5B2E9A8F
Modified: 2020-01-19 13:02 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (zi)


Attachments
/poudriere/data/wrkdirs/12amd64-default/default/work/getdns-1.5.2/config.log (111.40 KB, text/plain)
2020-01-19 12:44 UTC, p5B2E9A8F
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description p5B2E9A8F 2020-01-19 12:44:58 UTC
Created attachment 210864 [details]
/poudriere/data/wrkdirs/12amd64-default/default/work/getdns-1.5.2/config.log

checking for LibreSSL... yes
configure: error: getdns does not support LibreSSL
===>  Script "configure" failed unexpectedly.

From my reading getdns *should* build with LibreSSL ?
Comment 1 Ryan Steinmetz freebsd_committer freebsd_triage 2020-01-19 13:02:17 UTC
configure says it isn't supported:
configure: error: getdns does not support LibreSSL

Might be best to submit a patch upstream or reach out to the getdns developers:

https://github.com/getdnsapi/getdns