Bug 243553 - www/youtube_dl: Update to latest 2020.01.24
Summary: www/youtube_dl: Update to latest 2020.01.24
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Marcelo Araujo
URL:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2020-01-23 22:35 UTC by Conrad Meyer
Modified: 2020-02-07 18:20 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (araujo)


Attachments
Patch to update (872 bytes, patch)
2020-01-23 22:43 UTC, Conrad Meyer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Conrad Meyer freebsd_committer 2020-01-23 22:35:00 UTC
https://github.com/ytdl-org/youtube-dl/releases

youtube_dl 2019.11.28 is broken on, ironically, youtube.com now.  See upstream bug: https://github.com/ytdl-org/youtube-dl/issues/23819

The 2020-01-24 release includes a fix for it: "[youtube] Fix sigfunc name extraction".
Comment 1 Conrad Meyer freebsd_committer 2020-01-23 22:43:22 UTC
Created attachment 211001 [details]
Patch to update

Tested patch, confirmed it fixes youtube.com.
Comment 2 daniel.engberg.lists 2020-01-24 10:50:29 UTC
Hi,

I just pushed a new patch for this port on Phabricator and noticed your submission afterwards. It's identical to yours except that my also removes archivers/zip build dependency which I think is a welcome change. It's been open since the 24th Dec without any feedback from maintainer so it should be fine to commit due timeout?

https://reviews.freebsd.org/D22919

Best regards,
Daniel
Comment 3 Conrad Meyer freebsd_committer 2020-01-24 16:28:51 UTC
Hi Daniel,

That does seem like a nice change.  Unfortunately, I don't have a ports commit bit so we're still stuck waiting on someone with a ports bit to bless.

Cheers,
Conrad
Comment 4 commit-hook freebsd_committer 2020-02-07 18:17:50 UTC
A commit references this bug:

Author: swills
Date: Fri Feb  7 18:17:44 UTC 2020
New revision: 525494
URL: https://svnweb.freebsd.org/changeset/ports/525494

Log:
  www/youtube_dl: Update to latest 2020.01.24

  PR:		243553
  Submitted by:	cem
  Submitted by:	daniel.engberg.lists@pyret.net
  Approved by:	maintainer timeout (araujo, >2 weeks)
  Differential Revision:	https://reviews.freebsd.org/D22919

Changes:
  head/www/youtube_dl/Makefile
  head/www/youtube_dl/distinfo
  head/www/youtube_dl/files/patch-Makefile
Comment 5 Steve Wills freebsd_committer 2020-02-07 18:20:14 UTC
Committed, thanks!