Bug 243957 - emulators/i386-wine{-devel}: broken on CURRENT
Summary: emulators/i386-wine{-devel}: broken on CURRENT
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on: 243947
Blocks:
  Show dependency treegraph
 
Reported: 2020-02-07 13:11 UTC by Lorenzo Salvadore
Modified: 2020-02-08 20:23 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lorenzo Salvadore freebsd_committer 2020-02-07 13:11:38 UTC
/usr/bin/ldd32 is missing on CURRENT, at least for r356856 and r357262.

This breaks things such as emulator/i386-wine{-devel}: the ports gives many error messages regarding missing /usr/bin/ldd32 when building and attempts to run wine or winecfg results in the following error message:

ELF interpreter /libexec/ld-elf.so.1 not found, error 8
Abort trap

See bug #243947.

I open this bug report so that people who searches for bugs about wine can find it in a easier way and we can track issues specific to the wine context, if any.
Comment 1 Alex S 2020-02-07 14:31:55 UTC
That's curious. Can you run 32-bit binaries at all?
Comment 2 Lorenzo Salvadore freebsd_committer 2020-02-07 15:33:24 UTC
(In reply to Alex S from comment #1)

I guess not. I tried to compile a 32-bits application to test, but I was not able too. See my new comment on bug #243947.
If you want to suggest me some 32-bits application to test, I can try, but please suggest it in bug #233947: let's keep this one wine-specific.
Comment 3 Lorenzo Salvadore freebsd_committer 2020-02-07 15:34:12 UTC
(In reply to Lorenzo Salvadore from comment #2)

I meant bug #243947 of course, not #233947.
Comment 4 Alex S 2020-02-07 15:46:59 UTC
There is nothing Wine-specific there as far I am aware: i386-wine(-devel)/Makefile.inc doesn't explicitly call ldd32. It's better to close this issue altogether, it only contributes to confusion.
Comment 5 Lorenzo Salvadore freebsd_committer 2020-02-07 15:59:39 UTC
(In reply to Alex S from comment #4)

What's specific to wine is that wine is broken on CURRENT.

If a wine user wants to report that wine is broken on CURRENT, s/he might be tempted to open a PR about wine, although, as you observed, the problem is more general. The role of this PR is to point to the general PR, in a similar manner as what is usually done with complex exp-runs.
Other ports broken for the same reason should, in my opinion, have similar PRs that point to the general PR.

Moreover, it is indeed likely that the general problem will be solved without modifications to the wine ports and that those ports will then work again untouched, but the opposite is not impossible: it is not impossible that wine ports will need to change to integrate with the general solution.

That said, if bugzilla triagers or committers agree with you and want to close this PR, I will not object. I am only trying to adopt the best strategy to help people find existing bugs and understand the relations between them.
Comment 6 Lorenzo Salvadore freebsd_committer 2020-02-08 20:23:21 UTC
Everything works fine: the problem was my fault. For more details, please see bug #243947.