Bug 243982 - databases/datamodeler: update to 19.4.0.350.1424
Summary: databases/datamodeler: update to 19.4.0.350.1424
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Li-Wen Hsu
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-02-08 16:04 UTC by jjuanino
Modified: 2020-12-01 19:56 UTC (History)
3 users (show)

See Also:


Attachments
databases/datamodeler: update to 19.4.0.350.1424 (12.52 KB, patch)
2020-02-08 16:04 UTC, jjuanino
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jjuanino 2020-02-08 16:04:34 UTC
Created attachment 211475 [details]
databases/datamodeler: update to 19.4.0.350.1424

Release notes:

https://www.oracle.com/technetwork/developer-tools/datamodeler/downloads/dm-relnotes-194-5908939.html
Comment 1 Automation User 2020-02-08 18:26:04 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/116143367
Comment 2 commit-hook freebsd_committer 2020-06-28 13:32:33 UTC
A commit references this bug:

Author: lwhsu
Date: Sun Jun 28 13:32:29 UTC 2020
New revision: 540707
URL: https://svnweb.freebsd.org/changeset/ports/540707

Log:
  Update to 19.4.0.350.1424

  PR:		243982
  Submitted by:	jjuanino@gmail.com (maintainer)

Changes:
  head/databases/datamodeler/Makefile
  head/databases/datamodeler/distinfo
  head/databases/datamodeler/pkg-plist
Comment 3 Li-Wen Hsu freebsd_committer 2020-06-28 13:33:16 UTC
Committed, thanks. Can you also check the deprecation notice about "depends on expiring java/openjfx8-devel" ? Thanks!
Comment 4 jjuanino 2020-06-28 21:40:05 UTC
Hi, thanks for your work. I will soon send an update to avoid the deprecation notice. Regards.
Comment 5 Li-Wen Hsu freebsd_committer 2020-10-24 08:07:02 UTC
(In reply to jjuanino from comment #4)
ping, java/openjfx8-devel is going to expire on 11-30 if no further action.
Comment 6 jjuanino 2020-10-30 22:36:39 UTC
Hi, I am not sure whether this port will work entirely fine without openjfx8. Therefore,
reset the maintainership to ports@freebsd.org. Regards
Comment 7 Li-Wen Hsu freebsd_committer 2020-10-30 23:59:28 UTC
(In reply to jjuanino from comment #6)
Hi, thanks for your reply. I found there is java/openjfx14 added recently, could you help to check if it is fine to switch to use that?
Comment 8 jjuanino 2020-10-31 21:56:03 UTC
Hi, I have done some test and I can confirm that does not work. Datamodeler requires jdk version 8, not 11. Regards.
Comment 9 Rene Ladan freebsd_committer 2020-12-01 19:56:30 UTC
java/openjfx8-devel expired yesterday, so I removed this port as suggested in the comments.