Bug 244261 - Add support for Intel AX200 (iwx) wireless devices
Summary: Add support for Intel AX200 (iwx) wireless devices
Status: In Progress
Alias: None
Product: Base System
Classification: Unclassified
Component: wireless (show other bugs)
Version: 12.1-RELEASE
Hardware: Any Any
: --- Affects Only Me
Assignee: Bjoern A. Zeeb
Depends on:
Reported: 2020-02-21 05:41 UTC by Brian Zou
Modified: 2022-06-23 05:40 UTC (History)
52 users (show)

See Also:

TUXEDO Aura15 laptop (44 bytes, text/plain)
2021-03-15 11:25 UTC, alfredoFALK
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Zou 2020-02-21 05:41:50 UTC
OpenBSD be supported https://man.openbsd.org/man4/iwx.4
Comment 1 vidwer+fbsdbugs 2020-02-21 12:06:42 UTC
There are plans to port if_iwx, yes. I have ordered an adapter to work on, unless others beat me to it, in the (nearby) future. Might arrive somewhere in the next two months.

In the meanwhile, can you elaborate on 1) which laptop (or desktop) ships with AX200, and 2) provide some PCI ID details?
Comment 2 Gavin Atkinson freebsd_committer freebsd_triage 2020-02-21 15:02:12 UTC
Containing AX200 160MHz with PCI vendor 0x8086 device 0x2723:

- HP EliteBook HSN-122C
- HP EliteBook HSN-123C
- HP EliteBook HSN-124C-5
Comment 3 nomoo 2020-02-21 20:30:31 UTC
Good news! I'm ready to test with the following hardware:

Lenovo X1 Extreme Gen 2

AX200 160MHz: vendor 0x8086 device 0x2723
Comment 4 vidwer+fbsdbugs 2020-02-21 21:13:03 UTC
(In reply to Gavin Atkinson from comment #2)
Are those SKUs? Because HP's website doesn't retrieve those models: https://www8.hp.com/uk/en/search/search.html?nores=true&qt=HP%20EliteBook%20HSN-122C
Comment 5 Brian Zou 2020-02-23 10:20:51 UTC
ThinkPad X1 2019 Extreme Gen 2

Computer motherboard:
MSI Creator TRX40
MSI Creator X299

WIFI chip:
Comment 6 vidwer+fbsdbugs 2020-02-25 14:55:10 UTC
(In reply to vidwer+fbsdbugs from comment #4)
Quoting Gavin: "HSN-122: "EliteBook x360 830 G6"  HSN-123: "EliteBook 850 G6" and HSN-124: "EliteBook 840 G6""
Comment 7 vidwer+fbsdbugs 2020-03-24 11:20:01 UTC
Still working on the port.
Comment 8 vidwer+fbsdbugs 2020-03-24 11:21:25 UTC
Still working on the driver. Currently, while loading if_iwx it comes 'up' in dmesg with:

iwx0: <iwx22000_cfg, in need of a better name /* Intel(R) Dual Band Wireless AC 9260 */> mem 0xf0000000-0xf0003fff at device 0.0 on pci2
bus_dmamem_alloc failed to align memory properly.
bus_dmamem_alloc failed to align memory properly.
bus_dmamem_alloc failed to align memory properly.
bus_dmamem_alloc failed to align memory properly.
bus_dmamem_alloc failed to align memory properly.
bus_dmamem_alloc failed to align memory properly.
bus_dmamem_alloc failed to align memory properly.
bus_dmamem_alloc failed to align memory properly.
bus_dmamem_alloc failed to align memory properly.
iwx0: iwx_read_firmware: unknown firmware section 55, abort
iwx0: firmware parse error 22, section type 55
device_attach: iwx0 attach returned 6
Comment 9 vidwer+fbsdbugs 2020-04-21 11:27:20 UTC
Hi, I could use your help to make sc_debug actually show log output from IWX_DPRINTF().
sc_debug is (locally) set to 1 in iwx_attach(), in the SYSCTL_ADD_INT() macro and through dev.iwx.debug in /boot/loader.conf
Comment 10 delleceste 2020-04-25 10:17:53 UTC
Is there already a way to test the driver?
Will it support only G or also N / AX ?
Comment 11 vidwer+fbsdbugs 2020-04-25 21:04:19 UTC
(In reply to delleceste from comment #10)
Please contact the project leadership to move support for this particular hardware forward.
Comment 12 vidwer+fbsdbugs 2020-04-26 01:03:35 UTC
(In reply to vidwer+fbsdbugs from comment #9)

This is taken care of.
Comment 13 delleceste 2020-04-28 11:13:57 UTC
(In reply to vidwer+fbsdbugs from comment #11)
Thanks. I'm sorry I did not understand whom I should address to get this information. Is it wireless@freebsd.org?
Thank You
Kind regards
Comment 14 Bjoern A. Zeeb freebsd_committer 2020-05-20 16:33:47 UTC
I should probably take this given I am tasked to do 11ac for it which also means adding newer bits to the driver.  Don't hold your breath just yet.  I'll be a few weeks out at least.
Comment 15 Andreas Bjørnestad 2020-11-10 11:53:14 UTC
Will support for AX200 also include support for AX201?

From https://www.intel.com/content/www/us/en/support/articles/000054819/network-and-i-o/wireless.html:

The main difference between the two is that the Intel® Wi-Fi 6 AX201 is a CRF module that uses the Intel proprietary interface, and thus can only be used with select Intel chipsets and platforms.

Side-by-side comparison of AX200 and AX201: https://ark.intel.com/content/www/us/en/ark/compare.html?productIds=189347,130293

Waiting for FreeBSD to support AX201.
Comment 16 Bjoern A. Zeeb freebsd_committer 2020-11-10 12:14:25 UTC
(In reply to Andreas from comment #15)

yes it should support AX201 cards once the driver is finished.  If you have a chance to see if the old snapshot mentioned here[1] does attach and load firmware then we'd know for sure (it will not give any wifi!).
I don't have a AX201 to test with sadly.

[1] https://lists.freebsd.org/pipermail/freebsd-wireless/2020-July/009233.html
Comment 17 Andreas Bjørnestad 2020-11-10 13:02:19 UTC
(In reply to Bjoern A. Zeeb from comment #16)

Bjoern, thank you. I'm currently running 13.0-CURRENT, and doing a pciconf -vl gives me this:

none3@pci0:0:20:3:	class=0x028000 rev=0x00 hdr=0x00 vendor=0x8086 device=0x02f0 subvendor=0x8086 subdevice=0x0074
    vendor     = 'Intel Corporation'
    device     = 'Comet Lake PCH-LP CNVi WiFi'
    class      = network
Comment 18 Andreas Bjørnestad 2020-11-10 14:39:48 UTC
(In reply to Bjoern A. Zeeb from comment #16)
I assume that running 13.0-CURRENT would be the same (or better) as testing the old snaptshot that you linked to. Please correct me if this is wrong. I'll be happy to test.

I'm on a NUC10i7FNK (https://ark.intel.com/content/www/us/en/ark/products/188808/intel-nuc-10-performance-kit-nuc10i7fnk.html).
Comment 19 Bjoern A. Zeeb freebsd_committer 2020-11-10 14:56:50 UTC
(In reply to Andreas from comment #18)

The snapshot bits have mostly not yet been merged to head.  DRM is currently going in to linuxkpi and while we have conflicting bits DRM takes precedence at the moment.  I'll try and see if I can update the snapshot next weekend to a recent head.
Comment 20 Bjoern A. Zeeb freebsd_committer 2020-11-10 14:58:39 UTC
(In reply to Andreas from comment #17)

PCI IDs look supported;  basically everything in terms of HW interface that the Linux iwlwifi driver supports in the mvm parts (not the dwm which is iwn(4) in FreeBSD) is supposed to work.  All WiFi nits and bops and hooks and workarounds will take a bit longer.
Comment 21 Andreas Bjørnestad 2020-11-11 12:04:09 UTC
(In reply to Bjoern A. Zeeb from comment #16)

Bjoern, I 1)cloned the git repo to /usr/src (did cd /usr/src && rm -rf * to clean beforehand), then 2)make buildkernel KERNCONF=GENERIC and 3)make installkernel KERNCONF=GENERIC.

When I try to load, I get:

kldload if_iwl
kldload: can't load if_iwl: No such file or directory

I guess I didn't build it. Could you give me some directions what I have to change? My first kernel compilation ever (yay).
Comment 22 Master One 2021-01-27 05:58:05 UTC
It's been a while without any update to this issue. I'm not a dev but I guess it's not as easy as just porting over the iwx driver from OpenBSD?

I have two affected Clevo NV41MZ ultrabooks with AX200.
Comment 23 Dmitry Lukhtionov 2021-02-01 13:08:23 UTC
Containing AX200 160MHz with PCI vendor 0x8086 device 0x2723:

- Acer Swift 1 SF114-33
Comment 24 alfredoFALK 2021-03-15 11:25:18 UTC
Created attachment 223287 [details]
TUXEDO Aura15 laptop


Hardware info for this laptop
Comment 25 Martin Matuska freebsd_committer 2021-04-09 15:45:23 UTC
This card can be purchased separately in various flavors.

The product numbers are:
AX200.NGWG.DTK  (Desktop kit with M.2 card usable in notebooks)
AX200.NGWG.NV (M.2 card only)
Delock 89049 (PCIe 3.0 x1 card from Delock)
6VF53AA (PCIe card from HP)
Comment 26 Aaron B 2021-05-02 16:51:25 UTC
Same issue. I have a Lenovo Legion 5P 15IMH05H. Here's my pciconf -vl output:

none3@pci0:0:20:3: class=0x028000 rev=0x00 hdr=0x00 vendor=0x00 device=0x06f0 subvendor=0x8086 subdevice=0x0074

vendor=Intel Corporation
device=Comet Lake PCH CNVi WiFi
Comment 27 Aaron B 2021-05-02 16:59:19 UTC
(In reply to Aaron B from comment #26)

I forgot to mention this, but here is my HW-Probe: https://bsd-hardware.info/?probe=2be8cf963c
Comment 28 Ethan Atchley 2021-05-28 01:26:11 UTC
Here's my laptop that has the same type of card needs support:


OpenBSD does have support for it, so maybe it could be borrowed somehow?
Comment 29 Jack 2021-05-30 09:41:03 UTC
This motherboard also has this wifi card

        Manufacturer: Micro-Star International Co., Ltd.
        Product Name: MPG X570 GAMING PRO CARBON WIFI (MS-7B93)

none1@pci0:40:0:0:      class=0x028000 rev=0x1a hdr=0x00 vendor=0x8086 device=0x2723 subvendor=0x8086 subdevice=0x0084
    vendor     = 'Intel Corporation'
    device     = 'Wi-Fi 6 AX200'
    class      = network
Comment 30 alfredoFALK 2021-06-02 10:42:19 UTC
Hiya all, I am more than disappointed that freeBSD cannot come forward with this driver - module for the AX200 card (over a year delayed now)
OpenBSD runs perfectly on my laptop but "helloSystem OS" based on freeBSD13-RELEASE just does not.
That means I have to eliminate freeBSD from my laptop as a solution.
A pity ...
Comment 31 Master One 2021-06-03 03:06:15 UTC
@alfredoFALK It is indeed a pity that this has such a low priority, as a lot of current devices have such a wireless device nowadays. My intermediate solution for this problem was to get a cheap USB dongle, in my case a tp-link AC600, to be used till this issue gets solved.
Comment 32 Adriaan de Groot freebsd_committer 2021-06-11 14:27:33 UTC
(In reply to Andreas Bjørnestad from comment #17)
(In reply to Aaron B from comment #27)

Device:Subdevice 0x02f0:0x0074 'Comet Lake PCH-LP CNVi WiFi' and 0x06f0:0x0074 'Comet Lake PCH CNVi WiFi' might belong with PR 245304 instead. It's hard to tell exactly -- also on Linux I can find these devices associated with descriptive strings for AX200, AX201, and AC-9560
Comment 33 Aaron B 2021-06-11 14:59:16 UTC
(In reply to Adriaan de Groot from comment #32)

The website of my laptop lists it as Wi-Fi 6 (2x2 AX), I currently can't check the PR you linked because I'm not home and I don't have much time
Comment 34 Aaron B 2021-06-11 16:39:57 UTC
(In reply to Aaron B from comment #33)
(In reply to Adriaan de Groot from comment #32)

Fedora says its the AX201 -> https://imgur.com/a/vDXDFwj
Comment 35 Valenti 2021-06-21 16:09:08 UTC
Lenovo L13 with ax201 wifi 6. Same problem. Not detected for the kernel on FreeBSD 12.2 and 13.0 . There is any nearly solution? 
Thanks you. Detected and work on OpenFreeBSD
Comment 36 Valenti 2021-06-21 16:10:05 UTC
Lenovo L13 with ax201 wifi 6. Same problem. Not detected for the kernel on FreeBSD 12.2 and 13.0 . There is any nearly solution? 
Thanks you. Detected and work on OpenFreeBSD
Comment 37 Louis B 2021-07-13 13:38:13 UTC
I have a Thinkpad X1 Carbon 8th Gen. with this wireless card and it doesn't work.

Here is the probe:

I'd like to contribute in any way possible to get it working on FreeBSD. Source tree and old C books are ready to use :)
Comment 38 Bjoern A. Zeeb freebsd_committer 2021-09-06 18:42:48 UTC

I've put the 2nd snapshot for the driver out.  You are welcome to test:

Comment 39 yjqg6666 2021-10-12 00:52:12 UTC
I have a Thinkpad X1 Carbon 9th Gen. It's wireless card doesn't work for FreeBSD-13-Stable and FreeBSD14-Current.

Here is the probe:
from HelloSystem v0.6.0 with FreeBSD 12.2.

I'd like to help or test to get it working.

It's Wifi 6 AX201, 11ax. Does it support from the second snapshot? If supported, which FreeBSD version should I apply patches on and test, 14-Current or 13-Stable?
Comment 40 yjqg6666 2021-10-13 00:33:51 UTC

Tried the second snapshot on FreeBSD-14.0-CURRENT-amd64-20211008-67bceb38f46-249945 and it works. It may not working on ac mode.

The new probe is:

I reread the wiki. I will test it on https://download.freebsd.org/ftp/snapshots/amd64/amd64/ISO-IMAGES/13.0/FreeBSD-13.0-STABLE-amd64-20211007-b1cca743673-247549-memstick.img.
Comment 41 yjqg6666 2021-10-15 12:40:56 UTC
On FreeBSD-13-Stable with the second snapshot, it works on 802.11a mode. 

The new probe is: 


The bluetooth does not work/probed as expected.

When shutdown the os, there is a error related to iwlwifi driver. Here is the screenshot, https://pasteboard.co/MR9UOjmTjMgt.jpg .

Thanks for the ongoing works. Waiting for the final support for 802.11ax Wifi 6.
Comment 42 Bjoern A. Zeeb freebsd_committer 2021-10-21 14:04:50 UTC
(In reply to yjqg6666 from comment #41)

Thanks a lot for testing and reporting back.

What was your issue with bluetooth?
Comment 43 Kurt Jaeger freebsd_committer 2021-10-24 14:04:54 UTC
testbuild on a recent 14.0-CURRENT failed, see


Version was: main-n250238-dfd704b7fb2c
Comment 44 Bjoern A. Zeeb freebsd_committer 2021-10-24 21:09:57 UTC
(In reply to Kurt Jaeger from comment #43)

Well pi, that's because you didn't apply all the changes (and probably because they currently don't apply cleanly to main anymore given parts of them merged in and the rest (but drivers at least) are hopefully to follow this week).
Comment 45 Jeremy Beker 2021-10-28 14:48:31 UTC
So is it now not possible to test this? 

I was hoping to try as I got a new Dell laptop with an AX201.
Comment 46 Bjoern A. Zeeb freebsd_committer 2021-10-31 19:30:07 UTC
(In reply to Jeremy Beker from comment #45)

AX201 should work for as much as things work (see wiki page https://wiki.freebsd.org/WiFi/Iwlwifi).

I was hoping to have everything in HEAD by today but I hit a weird bug which appeared on the final kernel re-compile without relevant code changes;  something which Linux people have occasionally seen too (there is a lengthy bug report).

So it'll be some time next week for the last files to go in (Monday is a bank holiday here).   That should then solve all conflicts or rather have everything in HEAD).  I'll send an email to the wireless list and try to remember to also notify all open PRs.

For people on 13 things should then hopefully come a few days (a week-ish time) later.
Comment 47 j1 2021-12-09 01:07:00 UTC
I'm confused understanding where the compatibility table or this discussion is more recent. I want to buy the WiFi card which works best. Are both ax200 and ax201 supposed to work in ac mode with 13?
Comment 48 Bjoern A. Zeeb freebsd_committer 2021-12-09 14:04:55 UTC
(In reply to j1 from comment #47)

Currently the driver is not in stable/13 yet and it does not yet do 11ac but only a/b/g with 11n and 11ac coming after.

I was hoping to be further at this point in the year.  Sorry it is not there yet.

The driver is in HEAD but not enabled by default yet.  The last dependencies seem to get ready to be committed into HEAD and then will be merged to stable/13.

AX201, AX200 and AX210 are all expected to work hardware wise once the driver is enabled with more and more features and newer WiFi standards coming over time.
Comment 49 Jim D. 2021-12-21 20:10:10 UTC
(In reply to Jack from comment #29; and for future references)

FBSD-12.2 on MSI MEG X570 ACE (MS-7C35), BIOS 1F0

none1@pci0:40:0:0:	class=0x028000 card=0x00848086 chip=0x27238086 rev=0x1a hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Wi-Fi 6 AX200'
    class      = network
Comment 50 nbari 2022-01-01 13:10:12 UTC
Any idea about how to test or support testing from FreeBSD 13 stable? the output from pciconf -vl on my system (ROG CROSSHAIR VIII HERO (WI-FI) returns:

none0@pci0:6:0:0:       class=0x028000 rev=0x1a hdr=0x00 vendor=0x8086 device=0x2723 subvendor=0x8086 subdevice=0x0084
    vendor     = 'Intel Corporation'
    device     = 'Wi-Fi 6 AX200'
    class      = network
Comment 51 Tomasz "CeDeROM" CEDRO 2022-01-17 00:49:04 UTC
Hello world :-) Any clue if Bluetooth on this card would work on FreeBSD any soon? :-)
Comment 52 Bjoern A. Zeeb freebsd_committer 2022-01-17 01:15:41 UTC
(In reply to Tomasz "CeDeROM" CEDRO from comment #51)

Bluetooth support has its own open bugs, e.g. see the commits on this one:  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=260161
Comment 53 Bjoern A. Zeeb freebsd_committer 2022-01-17 01:17:44 UTC
(In reply to nbari from comment #50)

Testing stable/13 should be straight forward now;  just compile and load the driver as indicated in the man page (after installation).  Also see the freebsd-wireless mailing list for ongoing discussions about problems and fixes ( https://lists.freebsd.org/archives/freebsd-wireless/ )

The support for iwlwifi is work in progress and keeps moving so following there is probably best at this point.