Bug 245056 - net/spideroak: 'certificate verify failed' during setup
Summary: net/spideroak: 'certificate verify failed' during setup
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Nicola Vitale
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-25 16:21 UTC by Paul von Behren
Modified: 2020-03-25 16:21 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (nivit)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul von Behren 2020-03-25 16:21:29 UTC
Although spideroak installs okay (12.1-RELEASE-p3), setup (registering with SpiderOak's cloud servers) fails with 'certificate verify failed'. Completing setup is needed for all useful operations. 

This package is an unofficial (not distributed by SpiderOak) freebsd port of SpiderOak's Linux client. At this time, the pkg uses SpiderOak version 6.0.1 and SpiderOak is distributing version 7.5.0. Here's their explanation of this error https://spideroak.support/hc/en-us/articles/115005874603-SSL-Certificate-Verification-Error.
The tldr version is the package includes a certificate that is out of date. 

I did not participate in this freenas discussion, but it describes the problem and a workaround: https://www.ixsystems.com/community/threads/spideroak-help-fix-certificate-verify-failed-error-and-getting-spideroakone-7-2-0-working.69492/
I followed the procedure replacing some of the pkg-installed files with current one's from SpiderOak's Linux tarball) and setup works. 

I have a SpiderOak paid account and can test an updated pkg.